summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2010-04-08 15:31:05 +0000
committerChristian Birchinger <joker@gentoo.org>2010-04-08 15:31:05 +0000
commit8634b8f91346efbc1eefbbc8624cb7817b0c4ba3 (patch)
tree1ce41a3723232005039971c10c81375cdecb0197 /x11-misc/xdotool
parentuse nspr-config to determine includes/libdir (diff)
downloadgentoo-2-8634b8f91346efbc1eefbbc8624cb7817b0c4ba3.tar.gz
gentoo-2-8634b8f91346efbc1eefbbc8624cb7817b0c4ba3.tar.bz2
gentoo-2-8634b8f91346efbc1eefbbc8624cb7817b0c4ba3.zip
Version bump. Droped 2 patches that now seem unneeded, because the install target creates the needed directories now and the linker target got the LIBS moved at the end of the arguments.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xdotool')
-rw-r--r--x11-misc/xdotool/ChangeLog10
-rw-r--r--x11-misc/xdotool/xdotool-1.20100318.2737.ebuild43
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/xdotool/ChangeLog b/x11-misc/xdotool/ChangeLog
index e22fbad24223..50bbba7dd147 100644
--- a/x11-misc/xdotool/ChangeLog
+++ b/x11-misc/xdotool/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/xdotool
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.7 2010/01/14 07:30:32 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.8 2010/04/08 15:31:05 joker Exp $
+
+*xdotool-1.20100318.2737 (08 Apr 2010)
+
+ 08 Apr 2010; Christian Birchinger <joker@gentoo.org>
+ +xdotool-1.20100318.2737.ebuild:
+ Version bump. Droped 2 patches that now seem unneeded, because the install
+ target creates the needed directories now and the linker target got the
+ LIBS moved at the end of the arguments.
14 Jan 2010; Christian Birchinger <joker@gentoo.org>
xdotool-20091231.02.ebuild:
diff --git a/x11-misc/xdotool/xdotool-1.20100318.2737.ebuild b/x11-misc/xdotool/xdotool-1.20100318.2737.ebuild
new file mode 100644
index 000000000000..7ada69d25095
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-1.20100318.2737.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-1.20100318.2737.ebuild,v 1.1 2010/04/08 15:31:05 joker Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows."
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND="x11-libs/libXtst
+ x11-libs/libX11"
+
+RDEPEND="${DEPEND}"
+
+# The test want to manualy start Xvfb, wont use VirtualX and # it tries
+# to run a full gnome-session. For such a tiny application # i consider
+# it overkill to rewrite the test scripts to not use it's own X server
+# and add a full blown gnome just to run the tests.
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC LD
+ export LDFLAGS="$(raw-ldflags)"
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}