summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-11-20 21:27:19 +0000
committerMichael Januszewski <spock@gentoo.org>2004-11-20 21:27:19 +0000
commit2bb4a7f264b4562cdac1aa02c7bcb772a3a2df22 (patch)
tree7cc535d0c83e53e08a1a7e407d5d2610102b08cf /x11-misc
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-2bb4a7f264b4562cdac1aa02c7bcb772a3a2df22.tar.gz
gentoo-2-2bb4a7f264b4562cdac1aa02c7bcb772a3a2df22.tar.bz2
gentoo-2-2bb4a7f264b4562cdac1aa02c7bcb772a3a2df22.zip
Version bump.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfractint/ChangeLog8
-rw-r--r--x11-misc/xfractint/files/digest-xfractint-20.4.001
-rw-r--r--x11-misc/xfractint/xfractint-20.4.00.ebuild57
3 files changed, 65 insertions, 1 deletions
diff --git a/x11-misc/xfractint/ChangeLog b/x11-misc/xfractint/ChangeLog
index 9c8ddac9ac65..235c4e5de4b1 100644
--- a/x11-misc/xfractint/ChangeLog
+++ b/x11-misc/xfractint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xfractint
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/ChangeLog,v 1.28 2004/09/13 01:46:29 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/ChangeLog,v 1.29 2004/11/20 21:27:19 spock Exp $
+
+*xfractint-20.4.00 (20 Nov 2004)
+
+ 20 Nov 2004; Michal Januszewski <spock@gentoo.org>
+ +xfractint-20.4.00.ebuild:
+ Version bump.
12 Sep 2004; Jason Wever <weeve@gentoo.org> xfractint-20.3.02.ebuild:
Stable on sparc.
diff --git a/x11-misc/xfractint/files/digest-xfractint-20.4.00 b/x11-misc/xfractint/files/digest-xfractint-20.4.00
new file mode 100644
index 000000000000..c49f0d6e2a7e
--- /dev/null
+++ b/x11-misc/xfractint/files/digest-xfractint-20.4.00
@@ -0,0 +1 @@
+MD5 d0dcdea71cdabd80732b68b5bb1f0b77 xfract20.4.00.tar.gz 1056716
diff --git a/x11-misc/xfractint/xfractint-20.4.00.ebuild b/x11-misc/xfractint/xfractint-20.4.00.ebuild
new file mode 100644
index 000000000000..f943469eeeba
--- /dev/null
+++ b/x11-misc/xfractint/xfractint-20.4.00.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/xfractint-20.4.00.ebuild,v 1.1 2004/11/20 21:27:19 spock Exp $
+
+inherit eutils flag-o-matic
+
+MY_P=xfractint-20.04p00
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="The best fractal generator for X."
+HOMEPAGE="http://www.fractint.org"
+SRC_URI="http://www.fractint.org/ftp/current/linux/${P/int-/}.tar.gz"
+
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+SLOT="0"
+LICENSE="freedist"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-20.03p01-make.patch
+}
+
+src_compile() {
+ cd ${S}
+ cp Makefile Makefile.orig
+ replace-flags "-funroll-all-loops" "-funroll-loops"
+ sed -e "s:CFLAGS = :CFLAGS = $CFLAGS :" Makefile.orig >Makefile
+
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/xfractint
+ dodir /usr/man/man1
+
+ make \
+ BINDIR=${D}usr/bin \
+ MANDIR=${D}usr/man/man1 \
+ SRCDIR=${D}usr/share/xfractint \
+ install || die
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/xfractint.envd 60xfractint
+}
+
+pkg_postinst() {
+ einfo
+ einfo "XFractInt requires the FRACTDIR variable to be set in order to start."
+ einfo "Please re-login or \`source /etc/profile\` to have this variable set automatically."
+ einfo
+}