summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-01-21 21:19:16 +0000
committerPacho Ramos <pacho@gentoo.org>2013-01-21 21:19:16 +0000
commit2ca74390380c75e1f19d0d453a391bcf180b248d (patch)
treeda4a32d3f4be060e817d2144463ea6a81d01daf4 /x11-misc
parentUpdated HOMEPAGE, SRC_URI, and metadata (diff)
downloadgentoo-2-2ca74390380c75e1f19d0d453a391bcf180b248d.tar.gz
gentoo-2-2ca74390380c75e1f19d0d453a391bcf180b248d.tar.bz2
gentoo-2-2ca74390380c75e1f19d0d453a391bcf180b248d.zip
Fix udev rules installation dir (#453316 by Maciej Piechotka), doc files installation and use readme.gentoo.eclass to install configuration information.
(Portage version: 2.1.11.47/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bumblebee/ChangeLog10
-rw-r--r--x11-misc/bumblebee/bumblebee-3.0.1-r2.ebuild (renamed from x11-misc/bumblebee/bumblebee-3.0.1-r1.ebuild)21
-rw-r--r--x11-misc/bumblebee/bumblebee-3.0.1.ebuild69
3 files changed, 20 insertions, 80 deletions
diff --git a/x11-misc/bumblebee/ChangeLog b/x11-misc/bumblebee/ChangeLog
index 092fca36c6a4..f0ec931e381d 100644
--- a/x11-misc/bumblebee/ChangeLog
+++ b/x11-misc/bumblebee/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/bumblebee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/ChangeLog,v 1.10 2013/01/03 20:37:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/ChangeLog,v 1.11 2013/01/21 21:19:16 pacho Exp $
+
+*bumblebee-3.0.1-r2 (21 Jan 2013)
+
+ 21 Jan 2013; Pacho Ramos <pacho@gentoo.org> +bumblebee-3.0.1-r2.ebuild,
+ -bumblebee-3.0.1-r1.ebuild, -bumblebee-3.0.1.ebuild:
+ Fix udev rules installation dir (#453316 by Maciej Piechotka), doc files
+ installation and use readme.gentoo.eclass to install configuration
+ information.
*bumblebee-3.0.1-r1 (03 Jan 2013)
diff --git a/x11-misc/bumblebee/bumblebee-3.0.1-r1.ebuild b/x11-misc/bumblebee/bumblebee-3.0.1-r2.ebuild
index bb151726d90c..ce9f29954455 100644
--- a/x11-misc/bumblebee/bumblebee-3.0.1-r1.ebuild
+++ b/x11-misc/bumblebee/bumblebee-3.0.1-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/bumblebee-3.0.1-r1.ebuild,v 1.1 2013/01/03 20:37:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/bumblebee-3.0.1-r2.ebuild,v 1.1 2013/01/21 21:19:16 pacho Exp $
EAPI=5
-inherit eutils multilib systemd user
+inherit eutils multilib readme.gentoo systemd udev user
DESCRIPTION="Service providing elegant and stable means of managing Optimus graphics chipsets"
HOMEPAGE="https://github.com/Bumblebee-Project/Bumblebee"
@@ -31,6 +31,9 @@ DEPEND=">=sys-devel/autoconf-2.68
REQUIRED_USE="|| ( video_cards_nouveau video_cards_nvidia )"
src_prepare() {
+ DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
+ You may need to setup your /etc/bumblebee/bumblebee.conf"
+
# --wait option for rmmod is deprecated:
# https://github.com/Bumblebee-Project/Bumblebee/issues/283
epatch "${FILESDIR}/${P}-remove-wait.patch"
@@ -51,7 +54,9 @@ src_configure() {
CONF_MODPATH_NVIDIA=${nvpref}/lib,${nvpref}/extensions,${xorgpref}/drivers,${xorgpref}"
fi
- econf ${ECONF_PARAMS}
+ econf \
+ --docdir=/usr/share/doc/"${PF}" \
+ ${ECONF_PARAMS}
}
src_install() {
@@ -62,8 +67,9 @@ src_install() {
# Install udev rule to handle nvidia card switching,
# https://github.com/Bumblebee-Project/Bumblebee/issues/283
- insinto /usr/lib/udev/rules.d
- doins "${FILESDIR}"/99-remove-nvidia-dev.rules
+ udev_dorules "${FILESDIR}"/99-remove-nvidia-dev.rules
+
+ readme.gentoo_create_doc
default
}
@@ -74,8 +80,3 @@ pkg_preinst() {
enewgroup bumblebee
}
-
-pkg_postinst() {
- ewarn "In order to use Bumblebee, add your user to 'bumblebee' group."
- ewarn "You may need to setup your /etc/bumblebee/bumblebee.conf"
-}
diff --git a/x11-misc/bumblebee/bumblebee-3.0.1.ebuild b/x11-misc/bumblebee/bumblebee-3.0.1.ebuild
deleted file mode 100644
index 6d80803b675e..000000000000
--- a/x11-misc/bumblebee/bumblebee-3.0.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/bumblebee-3.0.1.ebuild,v 1.1 2012/09/14 20:24:21 pacho Exp $
-
-EAPI=4
-inherit multilib systemd user
-
-DESCRIPTION="Service providing elegant and stable means of managing Optimus graphics chipsets"
-HOMEPAGE="https://github.com/Bumblebee-Project/Bumblebee"
-SRC_URI="mirror://github/Bumblebee-Project/${PN/bu/Bu}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="+bbswitch video_cards_nouveau video_cards_nvidia"
-
-RDEPEND="x11-misc/virtualgl
- bbswitch? ( sys-power/bbswitch )
- virtual/opengl
- x11-base/xorg-drivers[video_cards_nvidia?,video_cards_nouveau?]"
-DEPEND=">=sys-devel/autoconf-2.68
- sys-devel/automake
- sys-devel/gcc
- virtual/pkgconfig
- dev-libs/glib:2
- x11-libs/libX11
- dev-libs/libbsd
- sys-apps/help2man"
-
-REQUIRED_USE="|| ( video_cards_nouveau video_cards_nvidia )"
-
-src_configure() {
- if use video_cards_nvidia ; then
- # Get paths to GL libs for all ABIs
- local nvlib=""
- for i in $(get_all_libdirs) ; do
- nvlib="${nvlib}:/usr/${i}/opengl/nvidia/lib"
- done
-
- local nvpref="/usr/$(get_libdir)/opengl/nvidia"
- local xorgpref="/usr/$(get_libdir)/xorg/modules"
- ECONF_PARAMS="CONF_DRIVER=nvidia CONF_DRIVER_MODULE_NVIDIA=nvidia \
- CONF_LDPATH_NVIDIA=${nvlib#:} \
- CONF_MODPATH_NVIDIA=${nvpref}/lib,${nvpref}/extensions,${xorgpref}/drivers,${xorgpref}"
- fi
-
- econf ${ECONF_PARAMS}
-}
-
-src_install() {
- newconfd "${FILESDIR}"/bumblebee.confd bumblebee
- newinitd "${FILESDIR}"/bumblebee.initd bumblebee
- newenvd "${FILESDIR}"/bumblebee.envd 99bumblebee
- systemd_dounit scripts/systemd/bumblebeed.service
- default
-}
-
-pkg_preinst() {
- use video_cards_nvidia || rm "${ED}"/etc/bumblebee/xorg.conf.nvidia
- use video_cards_nouveau || rm "${ED}"/etc/bumblebee/xorg.conf.nouveau
-
- enewgroup bumblebee
-}
-
-pkg_postinst() {
- ewarn "In order to use Bumblebee, add your user to 'bumblebee' group."
- ewarn "You may need to setup your /etc/bumblebee/bumblebee.conf"
-}