summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-19 16:34:15 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-19 16:34:15 +0000
commit3265ff2878efbf7713c756aa815d1a2ad7c6add2 (patch)
treeb0dedd7697ab63d31873b24c60007963cbb5a50b /x11-misc
parentOld. (diff)
downloadgentoo-2-3265ff2878efbf7713c756aa815d1a2ad7c6add2.tar.gz
gentoo-2-3265ff2878efbf7713c756aa815d1a2ad7c6add2.tar.bz2
gentoo-2-3265ff2878efbf7713c756aa815d1a2ad7c6add2.zip
New ebuild for x11-misc/mate-menu-editor, Mozo menu editor for MATE; imported from the mate-overlay, reviewed and adjusted.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mate-menu-editor/ChangeLog10
-rw-r--r--x11-misc/mate-menu-editor/mate-menu-editor-1.6.0.ebuild80
-rw-r--r--x11-misc/mate-menu-editor/metadata.xml8
3 files changed, 98 insertions, 0 deletions
diff --git a/x11-misc/mate-menu-editor/ChangeLog b/x11-misc/mate-menu-editor/ChangeLog
new file mode 100644
index 000000000000..7570140292ad
--- /dev/null
+++ b/x11-misc/mate-menu-editor/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/mate-menu-editor
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/mate-menu-editor/ChangeLog,v 1.1 2014/03/19 16:34:15 tomwij Exp $
+
+*mate-menu-editor-1.6.0 (19 Mar 2014)
+
+ 19 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +mate-menu-editor-1.6.0.ebuild,
+ +metadata.xml:
+ New ebuild for x11-misc/mate-menu-editor, Mozo menu editor for MATE; imported
+ from the mate-overlay, reviewed and adjusted.
diff --git a/x11-misc/mate-menu-editor/mate-menu-editor-1.6.0.ebuild b/x11-misc/mate-menu-editor/mate-menu-editor-1.6.0.ebuild
new file mode 100644
index 000000000000..c20dcef751a0
--- /dev/null
+++ b/x11-misc/mate-menu-editor/mate-menu-editor-1.6.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/mate-menu-editor/mate-menu-editor-1.6.0.ebuild,v 1.1 2014/03/19 16:34:15 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit autotools gnome2 python-r1 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Mozo menu editor for MATE"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND=">=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.6:0[introspection,python]"
+
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=mate-base/mate-panel-1.6:0
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:2[introspection]
+ virtual/libintl:0"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ # Tarball has no proper build system, should be fixed on next release.
+ eautoreconf
+
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+DOCS="AUTHORS NEWS README"
+
+src_install() {
+ installing() {
+ gnome2_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}
diff --git a/x11-misc/mate-menu-editor/metadata.xml b/x11-misc/mate-menu-editor/metadata.xml
new file mode 100644
index 000000000000..dca1781cb290
--- /dev/null
+++ b/x11-misc/mate-menu-editor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+</pkgmetadata>