summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-21 17:40:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-21 17:40:09 +0000
commit39a53a129c334a3c3b405aa37f4bca4441dde63c (patch)
tree36684764f497f112f7adbf5dd0eaa9447f6fd3aa /x11-misc
parentStable for x86, wrt bug #487360 (diff)
downloadgentoo-2-39a53a129c334a3c3b405aa37f4bca4441dde63c.tar.gz
gentoo-2-39a53a129c334a3c3b405aa37f4bca4441dde63c.tar.bz2
gentoo-2-39a53a129c334a3c3b405aa37f4bca4441dde63c.zip
fix import bug wrt #488866
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/menulibre/ChangeLog8
-rw-r--r--x11-misc/menulibre/files/menulibre-13.01.4-GError-import.patch17
-rw-r--r--x11-misc/menulibre/menulibre-13.01.4-r1.ebuild69
3 files changed, 93 insertions, 1 deletions
diff --git a/x11-misc/menulibre/ChangeLog b/x11-misc/menulibre/ChangeLog
index d33c68752b52..a3d903ded3da 100644
--- a/x11-misc/menulibre/ChangeLog
+++ b/x11-misc/menulibre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/menulibre
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/menulibre/ChangeLog,v 1.4 2013/06/25 12:52:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/menulibre/ChangeLog,v 1.5 2013/10/21 17:40:09 hasufell Exp $
+
+*menulibre-13.01.4-r1 (21 Oct 2013)
+
+ 21 Oct 2013; Julian Ospald <hasufell@gentoo.org>
+ +menulibre-13.01.4-r1.ebuild, +files/menulibre-13.01.4-GError-import.patch:
+ fix import bug wrt #488866
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> menulibre-13.01.4.ebuild:
Stable for amd64, wrt bug #474396
diff --git a/x11-misc/menulibre/files/menulibre-13.01.4-GError-import.patch b/x11-misc/menulibre/files/menulibre-13.01.4-GError-import.patch
new file mode 100644
index 000000000000..6a747ba07fb8
--- /dev/null
+++ b/x11-misc/menulibre/files/menulibre-13.01.4-GError-import.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Mon Oct 21 17:32:25 UTC 2013
+Subject: fix import
+
+https://bugs.gentoo.org/show_bug.cgi?id=488866
+
+--- a/menulibre_lib/IconTheme.py
++++ b/menulibre_lib/IconTheme.py
+@@ -15,7 +15,7 @@
+ ### END LICENSE
+
+ from gi.repository import Gtk, GdkPixbuf
+-from gi._glib import GError
++from gi._glib._glib import GError
+ import os
+
+ from menulibreconfig import get_data_file
diff --git a/x11-misc/menulibre/menulibre-13.01.4-r1.ebuild b/x11-misc/menulibre/menulibre-13.01.4-r1.ebuild
new file mode 100644
index 000000000000..3382d113b36b
--- /dev/null
+++ b/x11-misc/menulibre/menulibre-13.01.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/menulibre/menulibre-13.01.4-r1.ebuild,v 1.1 2013/10/21 17:40:09 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_REQ_USE="xml"
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit eutils gnome2-utils distutils-r1
+
+DESCRIPTION="An advanced menu editor that provides modern features in a clean, easy-to-use interface"
+HOMEPAGE="http://www.smdavis.us/projects/menulibre/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[X,introspection]
+ x11-libs/gtk+:3[X,introspection]
+ x11-themes/hicolor-icon-theme"
+
+PATCHES=( "${FILESDIR}"/${P}-GError-import.patch )
+
+S=${WORKDIR}/${PN}
+
+python_prepare_all() {
+ # too many categories
+ sed -i \
+ -e 's/X-GNOME-Settings-Panel;X-GNOME-PersonalSettings;DesktopSettings;X-XFCE;//' \
+ menulibre.desktop.in || die 'sed on menulibre.desktop.in failed'
+
+ local i
+ # fix incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ if [[ -n "${LINGUAS+x}" ]] ; then # if LINGUAS is set
+ for i in $(cd "${S}"/po ; for p in *.po ; do echo ${p%.po} ; done) ; do # for every supported language
+ if ! has ${i} ${LINGUAS} ; then # if language is disabled
+ rm po/${i}.po || die
+ fi
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s 32 help/C/figures/icon.png menu-editor.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ elog "optional dependencies:"
+ elog " gnome-extra/yelp (view help contents)"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}