summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-13 20:52:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-13 20:52:42 +0000
commita4b078a2003d5dc83616440bc8a68231c42b0c41 (patch)
tree91466c10b351132aeb263b76ebe2b5ea926a7330 /x11-misc
parentarm stable, bug #356545 (diff)
downloadgentoo-2-a4b078a2003d5dc83616440bc8a68231c42b0c41.tar.gz
gentoo-2-a4b078a2003d5dc83616440bc8a68231c42b0c41.tar.bz2
gentoo-2-a4b078a2003d5dc83616440bc8a68231c42b0c41.zip
PVersion bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/parcellite/ChangeLog10
-rw-r--r--x11-misc/parcellite/parcellite-1.0.1.ebuild45
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 1c71b0d00c65..d48378319dbb 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/parcellite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.10 2011/03/02 17:59:01 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.11 2011/03/13 20:52:42 hwoarang Exp $
+
+ 13 Mar 2011; Markos Chandras <hwoarang@gentoo.org> +parcellite-1.0.1.ebuild:
+ PVersion bump
+
+*parcellite-1.0.1 (13 Mar 2011)
+
+ 13 Mar 2011; Markos Chandras <hwoarang@gentoo.org> +parcellite-1.0.1.ebuild:
+ PVersion bump
02 Mar 2011; Kevin McCarthy <signals@gentoo.org> parcellite-0.9.1.ebuild:
Slotted gtk+ and glib depends and EAPI=2 bump to support it.
diff --git a/x11-misc/parcellite/parcellite-1.0.1.ebuild b/x11-misc/parcellite/parcellite-1.0.1.ebuild
new file mode 100644
index 000000000000..f4ebad67a45c
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.0.1.ebuild,v 1.1 2011/03/13 20:52:42 hwoarang Exp $
+
+EAPI=2
+inherit fdo-mime autotools
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager."
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=dev-libs/glib-2.14:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext
+ dev-util/intltool )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}