summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-26 12:28:32 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-26 12:28:32 +0000
commitbaac08c02292635648b13a457e0401c975b2057f (patch)
treec232c07f3f4235ae8a3c58841c28077bc6a82685 /x11-misc
parentStable for HPPA (bug #491948). (diff)
downloadgentoo-2-baac08c02292635648b13a457e0401c975b2057f.tar.gz
gentoo-2-baac08c02292635648b13a457e0401c975b2057f.tar.bz2
gentoo-2-baac08c02292635648b13a457e0401c975b2057f.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xnee/ChangeLog8
-rw-r--r--x11-misc/xnee/files/xnee-3.18-linker.patch10
-rw-r--r--x11-misc/xnee/xnee-3.18.ebuild73
3 files changed, 90 insertions, 1 deletions
diff --git a/x11-misc/xnee/ChangeLog b/x11-misc/xnee/ChangeLog
index 7155d80d6422..e7f7039db0ab 100644
--- a/x11-misc/xnee/ChangeLog
+++ b/x11-misc/xnee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xnee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.29 2014/01/30 11:34:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.30 2014/02/26 12:28:32 jer Exp $
+
+*xnee-3.18 (26 Feb 2014)
+
+ 26 Feb 2014; Jeroen Roovers <jer@gentoo.org> +xnee-3.18.ebuild,
+ +files/xnee-3.18-linker.patch:
+ Version bump.
*xnee-3.17 (30 Jan 2014)
diff --git a/x11-misc/xnee/files/xnee-3.18-linker.patch b/x11-misc/xnee/files/xnee-3.18-linker.patch
new file mode 100644
index 000000000000..b841bc0182e7
--- /dev/null
+++ b/x11-misc/xnee/files/xnee-3.18-linker.patch
@@ -0,0 +1,10 @@
+--- a/libxnee/src/Makefile.am
++++ b/libxnee/src/Makefile.am
+@@ -78,6 +78,7 @@
+ libxnee_la_LDFLAGS = -rpath '$(libdir)'
+ #dnl libxnee_la_SOURCES = $(LIB_XNEE_SOURCE_FILES)
+ libxnee_a_CFLAGS = $(AM_CFLAGS)
++libxnee_la_LIBADD = @X11_LIBS@
+
+ #noinst_LIBRARIES = libxnee.a
+
diff --git a/x11-misc/xnee/xnee-3.18.ebuild b/x11-misc/xnee/xnee-3.18.ebuild
new file mode 100644
index 000000000000..a2fb3b4e35b5
--- /dev/null
+++ b/x11-misc/xnee/xnee-3.18.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/xnee-3.18.ebuild,v 1.1 2014/02/26 12:28:32 jer Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Program suite to record, replay and distribute user actions."
+HOMEPAGE="http://www.sandklef.com/xnee/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome static-libs xosd"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXtst
+ x11-libs/libxcb
+ gnome? (
+ x11-libs/gtk+:2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gconf-2
+ )
+"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ virtual/pkgconfig
+ sys-devel/gettext
+ gnome? ( || (
+ media-gfx/imagemagick[jpeg,png]
+ media-gfx/graphicsmagick[imagemagick,jpeg,png]
+ ) )
+"
+
+# This needs RECORD extension from X.org server which isn't necessarily
+# enabled. Xlib: extension "RECORD" missing on display ":0.0".
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linker.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gnome gui) \
+ $(use_enable static-libs static) \
+ $(use_enable xosd buffer_verbose) \
+ $(use_enable xosd verbose) \
+ $(use_enable xosd) \
+ --disable-gnome-applet \
+ --disable-static-programs \
+ --enable-cli \
+ --enable-lib
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ default
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
+ use gnome && make_desktop_entry gnee Gnee ${PN} "Utility;GTK"
+ use static-libs || rm -f "${ED}"usr/lib*/lib*.la
+}