summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Woods <wwoods@gentoo.org>2003-05-12 22:47:25 +0000
committerWill Woods <wwoods@gentoo.org>2003-05-12 22:47:25 +0000
commit01218b525c35b14c644aa218bab1c20514a67088 (patch)
tree7732ddb6efa5c4e6733ae7a17b696e4341af46ef /x11-plugins/asmon
parentVersion bump (diff)
downloadgentoo-2-01218b525c35b14c644aa218bab1c20514a67088.tar.gz
gentoo-2-01218b525c35b14c644aa218bab1c20514a67088.tar.bz2
gentoo-2-01218b525c35b14c644aa218bab1c20514a67088.zip
initial version
Diffstat (limited to 'x11-plugins/asmon')
-rw-r--r--x11-plugins/asmon/ChangeLog9
-rw-r--r--x11-plugins/asmon/asmon-0.62.ebuild29
-rw-r--r--x11-plugins/asmon/files/asmon-alpha.diff24
-rw-r--r--x11-plugins/asmon/files/asmon-cflags.diff22
-rw-r--r--x11-plugins/asmon/files/digest-asmon-0.621
5 files changed, 85 insertions, 0 deletions
diff --git a/x11-plugins/asmon/ChangeLog b/x11-plugins/asmon/ChangeLog
new file mode 100644
index 000000000000..898aceaa683c
--- /dev/null
+++ b/x11-plugins/asmon/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/asmon
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asmon/ChangeLog,v 1.1 2003/05/12 22:46:35 wwoods Exp $
+
+*asmon-0.62 (12 May 2003)
+
+ 12 May 2003; Will Woods <wwoods@gentoo.org> asmon-0.62.ebuild:
+ Initial import. Comes with a patch to use CFLAGS and another to fix
+ CPU reporting on machines with high HZ values (e.g. alpha)
diff --git a/x11-plugins/asmon/asmon-0.62.ebuild b/x11-plugins/asmon/asmon-0.62.ebuild
new file mode 100644
index 000000000000..c0a60cdc8679
--- /dev/null
+++ b/x11-plugins/asmon/asmon-0.62.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asmon/asmon-0.62.ebuild,v 1.1 2003/05/12 22:46:35 wwoods Exp $
+# Short one-line description of this package.
+DESCRIPTION="WindowMaker/AfterStep system monitor dockapp"
+HOMEPAGE="http://rio.vg/asmon/"
+SRC_URI="http://www.tigr.net/afterstep/download/asmon/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 alpha"
+DEPEND="virtual/x11"
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/asmon-cflags.diff
+ epatch ${FILESDIR}/asmon-alpha.diff
+}
+
+src_compile() {
+ cd ${S}/asmon
+ make clean
+ emake || die
+}
+
+src_install() {
+ dodoc AUTHOR CHANGES Changelog INSTALL INSTALL.orig
+ cd asmon
+ dobin ${PN}
+}
diff --git a/x11-plugins/asmon/files/asmon-alpha.diff b/x11-plugins/asmon/files/asmon-alpha.diff
new file mode 100644
index 000000000000..c74524226199
--- /dev/null
+++ b/x11-plugins/asmon/files/asmon-alpha.diff
@@ -0,0 +1,24 @@
+--- asmon-0.62/asmon/asmon.c 2002-10-16 16:58:48.000000000 -0400
++++ asmon-0.62-ww/asmon/asmon.c 2003-05-12 12:39:03.000000000 -0400
+@@ -415,7 +415,7 @@
+ void DrawCPU(void)
+ {
+ static float cpustat[4]; /* remember the statistics read last time */
+- float fields[4], info[4], cputotal=0.0;
++ float fields[4], info[4], cputotal=0.0, cpuused=0.0;
+ long pageins=0, pageouts=0, swapins=0, swapouts=0;
+ int i;
+ #ifndef __FreeBSD__
+@@ -454,10 +454,11 @@
+ cpustat[i] = info[i];
+ }
+
++ cpuused = fields[0] + fields[1] + fields [2];
+ // CPU Bar
+ if(cputotal > 0)
+ {
+- cputotal = (cputotal-(fields[3]+fields[4]))*1.55;
++ cputotal = 27.0 * (cpuused/cputotal);
+ if ( cputotal > 26 ) cputotal = 26;
+ copyXPMArea(3,84,cputotal,9,5,5);
+ copyXPMArea(15,105,(27-cputotal),9,(5+cputotal),5);
diff --git a/x11-plugins/asmon/files/asmon-cflags.diff b/x11-plugins/asmon/files/asmon-cflags.diff
new file mode 100644
index 000000000000..9e029d79adeb
--- /dev/null
+++ b/x11-plugins/asmon/files/asmon-cflags.diff
@@ -0,0 +1,22 @@
+--- asmon-0.62/asmon/Makefile 2000-07-20 07:05:05.000000000 -0400
++++ asmon-0.62-ww/asmon/Makefile 2003-05-12 12:39:03.000000000 -0400
+@@ -18,16 +18,16 @@
+ ../wmgeneral/list.o
+
+ .c.o:
+- gcc -c -Wall $(SOLARIS) $< -o $*.o $(INCLUDES)
++ gcc -c -Wall $(CFLAGS) $(SOLARIS) $< -o $*.o $(INCLUDES)
+
+ asmon: $(OBJS)
+ gcc -o asmon $(OBJS) $(LIBDIR) $(LIBS) $(INCLUDES)
+
+ clean:
+ for i in $(OBJS) ; do \
+- rm $$i;\
++ rm -f $$i;\
+ done
+- rm asmon
++ rm -f asmon
+
+ install:
+ cp -f asmon $(PR_NAME); $(CHMOD_BSD)
diff --git a/x11-plugins/asmon/files/digest-asmon-0.62 b/x11-plugins/asmon/files/digest-asmon-0.62
new file mode 100644
index 000000000000..95c6de3e4693
--- /dev/null
+++ b/x11-plugins/asmon/files/digest-asmon-0.62
@@ -0,0 +1 @@
+MD5 d0f81aa0f1f1b5bc6214b127324b5cf4 asmon-0.62.tar.gz 2997