summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-10-10 19:11:01 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-10-10 19:11:01 +0000
commitbb8ff70e3e404ad38eb89733e977e0df4a26773c (patch)
tree39b114af74168ea78ffa3cb5853d07518b89331e /x11-plugins/astime/astime-2.8-r1.ebuild
parentModular X fixes, bug 147238. (diff)
downloadgentoo-2-bb8ff70e3e404ad38eb89733e977e0df4a26773c.tar.gz
gentoo-2-bb8ff70e3e404ad38eb89733e977e0df4a26773c.tar.bz2
gentoo-2-bb8ff70e3e404ad38eb89733e977e0df4a26773c.zip
Modular X fixes, bug 147239.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'x11-plugins/astime/astime-2.8-r1.ebuild')
-rw-r--r--x11-plugins/astime/astime-2.8-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/astime/astime-2.8-r1.ebuild b/x11-plugins/astime/astime-2.8-r1.ebuild
new file mode 100644
index 000000000000..fd556a834ce3
--- /dev/null
+++ b/x11-plugins/astime/astime-2.8-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/astime/astime-2.8-r1.ebuild,v 1.1 2006/10/10 19:11:01 kloeri Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Analogue clock utility for X Windows."
+HOMEPAGE="http://www.tigr.net/"
+SRC_URI="http://www.tigr.net/afterstep/download/astime/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="jpeg"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable jpeg) || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README
+}