summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-08-15 06:30:33 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-08-15 06:30:33 +0000
commitcba7c4ef53a39251607817e2822a376b2e0dbe8f (patch)
tree882a06d59a6877dfaaa7e7a98a8a1e741aea5848 /x11-plugins/gkrellm-seti
parentamd64 also needs nasm (Manifest recommit) (diff)
downloadgentoo-2-cba7c4ef53a39251607817e2822a376b2e0dbe8f.tar.gz
gentoo-2-cba7c4ef53a39251607817e2822a376b2e0dbe8f.tar.bz2
gentoo-2-cba7c4ef53a39251607817e2822a376b2e0dbe8f.zip
Patch to change the default data path to /var/lib/setiathome where gentoo puts it
Diffstat (limited to 'x11-plugins/gkrellm-seti')
-rw-r--r--x11-plugins/gkrellm-seti/ChangeLog7
-rw-r--r--x11-plugins/gkrellm-seti/files/gentoo-gkrellm-seti-path.patch11
-rw-r--r--x11-plugins/gkrellm-seti/gkrellm-seti-0.7.0b-r1.ebuild11
3 files changed, 26 insertions, 3 deletions
diff --git a/x11-plugins/gkrellm-seti/ChangeLog b/x11-plugins/gkrellm-seti/ChangeLog
index 53b84e8c4a1d..d49ed70f36c4 100644
--- a/x11-plugins/gkrellm-seti/ChangeLog
+++ b/x11-plugins/gkrellm-seti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrellm-seti
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-seti/ChangeLog,v 1.8 2004/06/24 22:57:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-seti/ChangeLog,v 1.9 2004/08/15 06:30:33 dragonheart Exp $
+
+ 15 Aug 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/gentoo-gkrellm-seti-path.patch, gkrellm-seti-0.7.0b-r1.ebuild:
+ Patch to change the default data path to /var/lib/setiathome where gentoo puts
+ it
28 Mar 2004; Markus Nigbur <pyrania@gentoo.org>
gkrellm-seti-0.7.0b-r1.ebuild:
diff --git a/x11-plugins/gkrellm-seti/files/gentoo-gkrellm-seti-path.patch b/x11-plugins/gkrellm-seti/files/gentoo-gkrellm-seti-path.patch
new file mode 100644
index 000000000000..27f5c7058937
--- /dev/null
+++ b/x11-plugins/gkrellm-seti/files/gentoo-gkrellm-seti-path.patch
@@ -0,0 +1,11 @@
+--- seti.c.orig 2004-08-15 14:49:49.434959464 +0930
++++ seti.c 2004-08-15 14:51:46.325189448 +0930
+@@ -1428,7 +1428,7 @@
+ style_id = gkrellm_add_meter_style(&plugin_mon, STYLE_NAME);
+
+ g_free(client_info.seti_file_path) ;
+- client_info.seti_file_path = g_strdup("/opt/setiathome/") ;
++ client_info.seti_file_path = g_strdup("/var/lib/setiathome/") ;
+
+ g_free(client_info.seti_client_path) ;
+ client_info.seti_client_path = g_strdup("/opt/setiathome/") ;
diff --git a/x11-plugins/gkrellm-seti/gkrellm-seti-0.7.0b-r1.ebuild b/x11-plugins/gkrellm-seti/gkrellm-seti-0.7.0b-r1.ebuild
index a7df14bc479b..ddfa6cb35cdf 100644
--- a/x11-plugins/gkrellm-seti/gkrellm-seti-0.7.0b-r1.ebuild
+++ b/x11-plugins/gkrellm-seti/gkrellm-seti-0.7.0b-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-seti/gkrellm-seti-0.7.0b-r1.ebuild,v 1.6 2004/06/24 22:57:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-seti/gkrellm-seti-0.7.0b-r1.ebuild,v 1.7 2004/08/15 06:30:33 dragonheart Exp $
+
+inherit eutils
IUSE=""
S=${WORKDIR}/${P//gkrellm-}
@@ -14,10 +16,15 @@ SLOT="2"
LICENSE="GPL-2"
KEYWORDS="x86 sparc ~alpha"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/gentoo-gkrellm-seti-path.patch || die "failed to apply patch"
mv ${WORKDIR}/Makefile ${S}
mv ${WORKDIR}/seti.c ${S}
mv ${WORKDIR}/seti.h ${S}
+}
+
+src_compile() {
make || die
}