summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-07-28 14:00:10 +0000
committerJim Ramsay <lack@gentoo.org>2008-07-28 14:00:10 +0000
commitaa0c19cada534e30cb34395c60b554f08123f5e8 (patch)
treef740f95a0d5781207573cdc3603c4386b72bdd7c /x11-plugins/gkrellmss
parentRemoved nokia6600 USE flag from libwbxml (diff)
downloadgentoo-2-aa0c19cada534e30cb34395c60b554f08123f5e8.tar.gz
gentoo-2-aa0c19cada534e30cb34395c60b554f08123f5e8.tar.bz2
gentoo-2-aa0c19cada534e30cb34395c60b554f08123f5e8.zip
Added 'die' if you try to build without at least one of USE=alsa or USE=esd (Bug #233025)
(Portage version: 2.2_rc3/cvs/Linux 2.6.23-gentoo-r5 i686)
Diffstat (limited to 'x11-plugins/gkrellmss')
-rw-r--r--x11-plugins/gkrellmss/ChangeLog7
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild8
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6.ebuild10
3 files changed, 21 insertions, 4 deletions
diff --git a/x11-plugins/gkrellmss/ChangeLog b/x11-plugins/gkrellmss/ChangeLog
index f58ff446f042..acfd934fcdd0 100644
--- a/x11-plugins/gkrellmss/ChangeLog
+++ b/x11-plugins/gkrellmss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrellmss
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/ChangeLog,v 1.26 2008/04/11 15:12:26 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/ChangeLog,v 1.27 2008/07/28 14:00:10 lack Exp $
+
+ 28 Jul 2008; Jim Ramsay <lack@gentoo.org> gkrellmss-2.6.ebuild,
+ gkrellmss-2.6-r1.ebuild:
+ Added 'die' if you try to build without at least one of USE=alsa or
+ USE=esd (Bug #233025)
*gkrellmss-2.6-r1 (11 Apr 2008)
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
index d3cd1fba0730..49ff2cabd84c 100644
--- a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild,v 1.1 2008/04/11 15:12:26 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild,v 1.2 2008/07/28 14:00:10 lack Exp $
inherit gkrellm-plugin
@@ -23,6 +23,12 @@ KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
PLUGIN_SO="src/gkrellmss.so"
PLUGIN_DOCS="Themes"
+pkg_preinst() {
+ if ! use esd && ! use alsa; then
+ die "You must enable at least one of USE=esd or USE=alsa"
+ fi
+}
+
src_compile() {
local myconf
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
index cb2e906b1380..6ed3a2aa2e7f 100644
--- a/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild,v 1.10 2007/07/11 20:39:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild,v 1.11 2008/07/28 14:00:10 lack Exp $
inherit gkrellm-plugin
@@ -23,6 +23,12 @@ KEYWORDS="~alpha amd64 ppc sparc x86"
PLUGIN_SO="src/gkrellmss.so"
PLUGIN_DOCS="Themes"
+pkg_preinst() {
+ if ! use esd && ! use alsa; then
+ die "You must enable at least one of USE=esd or USE=alsa"
+ fi
+}
+
src_compile() {
local myconf