summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-08-11 13:59:11 +0000
committerJim Ramsay <lack@gentoo.org>2010-08-11 13:59:11 +0000
commit867196d3e942e540d03bd6098de177b66b0f465c (patch)
tree79a70a8f0889b13defa25719f27d53557be93259 /x11-plugins/gkrellsun
parentFix building with GLIBC 2.12 wrt #332237 by Diego E. Pettenò. (diff)
downloadgentoo-2-867196d3e942e540d03bd6098de177b66b0f465c.tar.gz
gentoo-2-867196d3e942e540d03bd6098de177b66b0f465c.tar.bz2
gentoo-2-867196d3e942e540d03bd6098de177b66b0f465c.zip
Respect LDFLAGS (Bug #332223)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/gkrellsun')
-rw-r--r--x11-plugins/gkrellsun/ChangeLog8
-rw-r--r--x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch13
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild29
3 files changed, 49 insertions, 1 deletions
diff --git a/x11-plugins/gkrellsun/ChangeLog b/x11-plugins/gkrellsun/ChangeLog
index 719e63727658..eddc4e7f1968 100644
--- a/x11-plugins/gkrellsun/ChangeLog
+++ b/x11-plugins/gkrellsun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/gkrellsun
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.28 2010/07/28 14:41:54 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.29 2010/08/11 13:59:11 lack Exp $
+
+*gkrellsun-1.0.0-r3 (11 Aug 2010)
+
+ 11 Aug 2010; Jim Ramsay <lack@gentoo.org> +gkrellsun-1.0.0-r3.ebuild,
+ +files/gkrellsun-1.0.0-Respect-LDFLAGS.patch:
+ Respect LDFLAGS (Bug #332223)
*gkrellsun-1.0.0-r2 (28 Jul 2010)
diff --git a/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..548039dd0e0b
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/src20/Makefile b/src20/Makefile
+index 3e8e62c..ef96fa2 100644
+--- a/src20/Makefile
++++ b/src20/Makefile
+@@ -16,6 +16,8 @@ FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
++LFLAGS += $(LDFLAGS)
++
+ ifeq ($(enable_nls),1)
+ FLAGS += -DENABLE_NLS -DLOCALEDIR=\"$(LOCALEDIR)\"
+ export enable_nls
diff --git a/x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild
new file mode 100644
index 000000000000..5abaa34ea028
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild,v 1.1 2010/08/11 13:59:11 lack Exp $
+
+EAPI="3"
+inherit gkrellm-plugin eutils
+
+IUSE="nls"
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times."
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+PLUGIN_SO=src20/gkrellsun.so
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-reenable.patch"
+ epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ use nls && myconf="$myconf enable_nls=1"
+ emake ${myconf}
+}