summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-05-10 18:20:14 +0000
committerJim Ramsay <lack@gentoo.org>2011-05-10 18:20:14 +0000
commit0c6b220725135d257238bd916b08fbf978c7d728 (patch)
tree5d72826f1926c1e737d0fc0c5c26f0e63a7360af /x11-plugins/gkrellweather
parentRevision bump. Switch to EAPI 4. Add desktop file. Update desktop database. A... (diff)
downloadgentoo-2-0c6b220725135d257238bd916b08fbf978c7d728.tar.gz
gentoo-2-0c6b220725135d257238bd916b08fbf978c7d728.tar.bz2
gentoo-2-0c6b220725135d257238bd916b08fbf978c7d728.zip
Bug #363593 - Version bump
(Portage version: 2.1.9.34/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/gkrellweather')
-rw-r--r--x11-plugins/gkrellweather/ChangeLog11
-rw-r--r--x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch56
-rw-r--r--x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch25
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.8.ebuild36
4 files changed, 126 insertions, 2 deletions
diff --git a/x11-plugins/gkrellweather/ChangeLog b/x11-plugins/gkrellweather/ChangeLog
index f2b1f7ee127e..cc38b7ac5287 100644
--- a/x11-plugins/gkrellweather/ChangeLog
+++ b/x11-plugins/gkrellweather/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/gkrellweather
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/ChangeLog,v 1.32 2010/08/25 00:44:14 lack Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/ChangeLog,v 1.33 2011/05/10 18:20:14 lack Exp $
+
+*gkrellweather-2.0.8 (10 May 2011)
+
+ 10 May 2011; Jim Ramsay <lack@gentoo.org> +gkrellweather-2.0.8.ebuild,
+ +files/gkrellweather-2.0.8-Move-GrabWeather.patch,
+ +files/gkrellweather-2.0.8-Respect-LDFLAGS.patch:
+ Bug #363593 - Version bump
*gkrellweather-2.0.7-r2 (25 Aug 2010)
diff --git a/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch
new file mode 100644
index 000000000000..5e2eb95e33fc
--- /dev/null
+++ b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch
@@ -0,0 +1,56 @@
+From dc0fed370865b49e9bcb2db2eb7ff21adec904a8 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <lack@gentoo.org>
+Date: Tue, 24 Aug 2010 12:23:25 -0400
+Subject: [PATCH] Move GrabWeather script to $(PREFIX)/libexec/gkrellweather/
+
+This is to avoid a file collision with x11-misc/bbweather (Bug #333289)
+---
+ Makefile | 4 ++--
+ gkrellweather.c | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d6dc404..693b4f2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -38,13 +38,13 @@ install:
+ else \
+ install -D -c -s -m 644 gkrellweather.so $(PREFIX)/lib/gkrellm2/plugins/gkrellweather.so ; \
+ fi
+- install -c -m 755 GrabWeather $(PREFIX)/bin
++ install -D -c -m 755 GrabWeather $(PREFIX)/libexec/gkrellweather/
+
+ uninstall:
+ (cd po && ${MAKE} uninstall )
+ rm -f /usr/lib/gkrellm2/plugins/gkrellweather.so
+ rm -f $(PREFIX)/lib/gkrellm2/plugins/gkrellweather.so
+- rm -f $(PREFIX)/bin/GrabWeather
++ rm -f $(PREFIX)/libexec/gkrellweather/GrabWeather
+
+ dist:
+ rm -rf $(PKGNAME)-$(VERSION)
+diff --git a/gkrellweather.c b/gkrellweather.c
+index 1d4cf4e..224260a 100644
+--- a/gkrellweather.c
++++ b/gkrellweather.c
+@@ -721,7 +721,7 @@ apply_air_config (void)
+ options.station[1] = c[1];
+ options.station[2] = c[2];
+ options.station[3] = c[3];
+- snprintf(options.command, 512, PREFIX "/bin/GrabWeather %s", options.station);
++ snprintf(options.command, 512, PREFIX "/libexec/gkrellweather/GrabWeather %s", options.station);
+ options.command[511] = 0;
+ snprintf(options.filename, 512, "%s/.wmWeatherReports/%s.dat",
+ getenv("HOME"), options.station);
+@@ -986,7 +986,7 @@ read_default(void)
+ options.windspeed_unit = 1;
+ options.pressure_unit = 1;
+ strcpy(options.station, DEFAULT_STATION_ID);
+- snprintf(options.command, 512, "/usr/share/gkrellm/GrabWeather %s", options.station);
++ snprintf(options.command, 512, PREFIX "/libexec/gkrellweather/GrabWeather %s", options.station);
+ options.command[511] = 0;
+ snprintf(options.filename, 512, "%s/.wmWeatherReports/%s.dat",
+ getenv("HOME"), options.station);
+--
+1.7.2
+
diff --git a/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..9256cdd919c8
--- /dev/null
+++ b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch
@@ -0,0 +1,25 @@
+From 82c3a24ef34c5a5388ee9cc40126b3381fb8445a Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <lack@gentoo.org>
+Date: Wed, 11 Aug 2010 09:03:13 -0400
+Subject: [PATCH] Respect LDFLAGS
+
+---
+ Makefile | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d6dc404..46074ab 100644
+--- a/Makefile
++++ b/Makefile
+@@ -5,6 +5,8 @@ LIBS = `pkg-config gtk+-2.0 --libs`
+ LFLAGS = -shared
+ PREFIX = /usr/local
+
++LFLAGS += $(LDFLAGS)
++
+ LOCALEDIR := $(PREFIX)/share/locale
+
+ ifeq ($(enable_nls),1)
+--
+1.7.2
+
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.8.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.8.ebuild
new file mode 100644
index 000000000000..31b8fe7f5593
--- /dev/null
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/gkrellweather-2.0.8.ebuild,v 1.1 2011/05/10 18:20:14 lack Exp $
+
+EAPI=3
+inherit gkrellm-plugin
+
+IUSE=""
+DESCRIPTION="GKrellM2 Plugin that monitors a METAR station and displays weather
+info"
+SRC_URI="http://sites.google.com/site/makovick/projects/${P}.tgz"
+HOMEPAGE="http://sites.google.com/site/makovick/gkrellm-plugins"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=net-misc/wget-1.5.3"
+DEPEND=">=sys-apps/sed-4.0.5"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+ epatch "${FILESDIR}/${P}-Move-GrabWeather.patch"
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install () {
+ gkrellm-plugin_src_install
+
+ exeinto /usr/libexec/gkrellweather
+ doexe GrabWeather
+}