summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-08-25 00:44:14 +0000
committerJim Ramsay <lack@gentoo.org>2010-08-25 00:44:14 +0000
commit3df767dcd2e72088bf07d490f690a92d85d7652a (patch)
tree28f9e98ef7af8bbb1da1f978caf8024c3984c0b8 /x11-plugins/gkrellweather
parentBlock x11-plugins/gkrellweather for file collision (Bug #333289) (diff)
downloadgentoo-2-3df767dcd2e72088bf07d490f690a92d85d7652a.tar.gz
gentoo-2-3df767dcd2e72088bf07d490f690a92d85d7652a.tar.bz2
gentoo-2-3df767dcd2e72088bf07d490f690a92d85d7652a.zip
Move the GrabWeather script due to collision with x11-misc/bbweather (Bug #333289)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/gkrellweather')
-rw-r--r--x11-plugins/gkrellweather/ChangeLog10
-rw-r--r--x11-plugins/gkrellweather/files/gkrellweather-2.0.7-Move-GrabWeather.patch56
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.7-r1.ebuild5
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.7-r2.ebuild36
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.7.ebuild5
5 files changed, 107 insertions, 5 deletions
diff --git a/x11-plugins/gkrellweather/ChangeLog b/x11-plugins/gkrellweather/ChangeLog
index f125cb25dcef..f2b1f7ee127e 100644
--- a/x11-plugins/gkrellweather/ChangeLog
+++ b/x11-plugins/gkrellweather/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/gkrellweather
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/ChangeLog,v 1.31 2010/08/11 13:16:38 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/ChangeLog,v 1.32 2010/08/25 00:44:14 lack Exp $
+
+*gkrellweather-2.0.7-r2 (25 Aug 2010)
+
+ 25 Aug 2010; Jim Ramsay <lack@gentoo.org> gkrellweather-2.0.7.ebuild,
+ gkrellweather-2.0.7-r1.ebuild, +gkrellweather-2.0.7-r2.ebuild,
+ +files/gkrellweather-2.0.7-Move-GrabWeather.patch:
+ Move the GrabWeather script due to collision with x11-misc/bbweather (Bug
+ #333289)
*gkrellweather-2.0.7-r1 (11 Aug 2010)
diff --git a/x11-plugins/gkrellweather/files/gkrellweather-2.0.7-Move-GrabWeather.patch b/x11-plugins/gkrellweather/files/gkrellweather-2.0.7-Move-GrabWeather.patch
new file mode 100644
index 000000000000..592735b6956c
--- /dev/null
+++ b/x11-plugins/gkrellweather/files/gkrellweather-2.0.7-Move-GrabWeather.patch
@@ -0,0 +1,56 @@
+From dc0fed370865b49e9bcb2db2eb7ff21adec904a8 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <lack@gentoo.org>
+Date: Tue, 24 Aug 2010 12:23:25 -0400
+Subject: [PATCH] Move GrabWeather script to $(PREFIX)/libexec/gkrellweather/
+
+This is to avoid a file collision with x11-misc/bbweather (Bug #333289)
+---
+ Makefile | 4 ++--
+ gkrellweather.c | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d6dc404..693b4f2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -38,13 +38,13 @@ install:
+ else \
+ install -D -c -s -m 644 gkrellweather.so $(PREFIX)/lib/gkrellm2/plugins/gkrellweather.so ; \
+ fi
+- install -c -m 755 GrabWeather $(PREFIX)/bin
++ install -D -c -m 755 GrabWeather $(PREFIX)/libexec/gkrellweather/
+
+ uninstall:
+ (cd po && ${MAKE} uninstall )
+ rm -f /usr/lib/gkrellm2/plugins/gkrellweather.so
+ rm -f $(PREFIX)/lib/gkrellm2/plugins/gkrellweather.so
+- rm -f $(PREFIX)/bin/GrabWeather
++ rm -f $(PREFIX)/libexec/gkrellweather/GrabWeather
+
+ dist:
+ rm -rf $(PKGNAME)-$(VERSION)
+diff --git a/gkrellweather.c b/gkrellweather.c
+index 1d4cf4e..224260a 100644
+--- a/gkrellweather.c
++++ b/gkrellweather.c
+@@ -714,7 +714,7 @@ apply_air_config (void)
+ options.station[1] = c[1];
+ options.station[2] = c[2];
+ options.station[3] = c[3];
+- sprintf(options.command, PREFIX "/bin/GrabWeather %s", options.station);
++ sprintf(options.command, PREFIX "/libexec/gkrellweather/GrabWeather %s", options.station);
+ sprintf(options.filename, "%s/.wmWeatherReports/%s.dat",
+ getenv("HOME"), options.station);
+ net_update = FALSE;
+@@ -977,7 +977,7 @@ read_default(void)
+ options.windspeed_unit = 1;
+ options.pressure_unit = 1;
+ strcpy(options.station, DEFAULT_STATION_ID);
+- sprintf(options.command, "/usr/share/gkrellm/GrabWeather %s", options.station);
++ sprintf(options.command, PREFIX "/libexec/gkrellweather/GrabWeather %s", options.station);
+ sprintf(options.filename, "%s/.wmWeatherReports/%s.dat",
+ getenv("HOME"), options.station);
+ }
+--
+1.7.2
+
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.7-r1.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.7-r1.ebuild
index 46733d583fa4..47264c96c241 100644
--- a/x11-plugins/gkrellweather/gkrellweather-2.0.7-r1.ebuild
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/gkrellweather-2.0.7-r1.ebuild,v 1.1 2010/08/11 13:16:38 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/gkrellweather-2.0.7-r1.ebuild,v 1.2 2010/08/25 00:44:14 lack Exp $
EAPI=3
inherit gkrellm-plugin
@@ -16,7 +16,8 @@ LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
RDEPEND=">=dev-lang/perl-5.6.1
- >=net-misc/wget-1.5.3"
+ >=net-misc/wget-1.5.3
+ !x11-misc/bbweather"
DEPEND=">=sys-apps/sed-4.0.5"
src_prepare() {
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.7-r2.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..f63333f25812
--- /dev/null
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.7-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/gkrellweather-2.0.7-r2.ebuild,v 1.1 2010/08/25 00:44:14 lack Exp $
+
+EAPI=3
+inherit gkrellm-plugin
+
+IUSE=""
+DESCRIPTION="GKrellM2 Plugin that monitors a METAR station and displays weather
+info"
+SRC_URI="http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/${P}.tgz"
+HOMEPAGE="http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/index.html"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=net-misc/wget-1.5.3"
+DEPEND=">=sys-apps/sed-4.0.5"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+ epatch "${FILESDIR}/${P}-Move-GrabWeather.patch"
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install () {
+ gkrellm-plugin_src_install
+
+ exeinto /usr/libexec/gkrellweather
+ doexe GrabWeather
+}
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.7.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.7.ebuild
index 6492fcdf6044..2a72ed4a8c41 100644
--- a/x11-plugins/gkrellweather/gkrellweather-2.0.7.ebuild
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/gkrellweather-2.0.7.ebuild,v 1.8 2010/07/22 14:42:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/gkrellweather-2.0.7.ebuild,v 1.9 2010/08/25 00:44:14 lack Exp $
inherit gkrellm-plugin
@@ -15,7 +15,8 @@ LICENSE="GPL-2"
KEYWORDS="alpha amd64 ppc sparc x86"
RDEPEND=">=dev-lang/perl-5.6.1
- >=net-misc/wget-1.5.3"
+ >=net-misc/wget-1.5.3
+ !x11-misc/bbweather"
DEPEND=">=sys-apps/sed-4.0.5"
src_unpack() {