summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:09:12 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:09:12 +0000
commitb690002f7594232f704a19cd9f083b9d067f9c1c (patch)
treee9faf000a13d14c34cca2722a1ac6ef78bba2d90 /x11-plugins/guifications
parentReadd scripts to gentoo tarball (#281591). (diff)
downloadgentoo-2-b690002f7594232f704a19cd9f083b9d067f9c1c.tar.gz
gentoo-2-b690002f7594232f704a19cd9f083b9d067f9c1c.tar.bz2
gentoo-2-b690002f7594232f704a19cd9f083b9d067f9c1c.zip
Migrate to EAPI 2 in order to get rid of built_with_use.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/guifications')
-rw-r--r--x11-plugins/guifications/ChangeLog6
-rw-r--r--x11-plugins/guifications/guifications-2.16.ebuild22
2 files changed, 13 insertions, 15 deletions
diff --git a/x11-plugins/guifications/ChangeLog b/x11-plugins/guifications/ChangeLog
index 84b83413361d..de92cdcb593d 100644
--- a/x11-plugins/guifications/ChangeLog
+++ b/x11-plugins/guifications/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/guifications
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/ChangeLog,v 1.60 2009/08/16 09:06:14 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/ChangeLog,v 1.61 2009/08/16 09:09:12 betelgeuse Exp $
+
+ 16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ guifications-2.16.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
-guifications-2.14.ebuild:
diff --git a/x11-plugins/guifications/guifications-2.16.ebuild b/x11-plugins/guifications/guifications-2.16.ebuild
index ec0a6f988a00..4f48b071dc54 100644
--- a/x11-plugins/guifications/guifications-2.16.ebuild
+++ b/x11-plugins/guifications/guifications-2.16.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.8 2008/02/21 20:25:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.9 2009/08/16 09:09:12 betelgeuse Exp $
+
+EAPI="2"
inherit eutils
@@ -17,27 +19,19 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc sparc x86"
IUSE="debug nls"
-RDEPEND="net-im/pidgin
+RDEPEND="net-im/pidgin[gtk]
>=x11-libs/gtk+-2"
DEPEND="${DEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
-src_compile() {
+src_configure() {
econf \
$(use_enable debug ) \
$(use_enable nls) || die "econf failure"
- emake || die "emake failure"
}
src_install() {
- make install DESTDIR="${D}" || die "make install failure"
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION
+ emake install DESTDIR="${D}" || die "make install failure"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION || die
}