summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-10-15 09:54:42 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-10-15 09:54:42 +0000
commitb5bcd6dad2d5acff96d054580fcf361ff80c6dbc (patch)
treec2b5d9c89a8495a78a73b315da2ed225e025134c /x11-plugins/msn-pecan/msn-pecan-0.1.4.ebuild
parentInitial import from qt overlay. New razor-qt 0.5.0 release. (diff)
downloadgentoo-2-b5bcd6dad2d5acff96d054580fcf361ff80c6dbc.tar.gz
gentoo-2-b5bcd6dad2d5acff96d054580fcf361ff80c6dbc.tar.bz2
gentoo-2-b5bcd6dad2d5acff96d054580fcf361ff80c6dbc.zip
Version bump, ebuild cleanup and EAPI bump, remove old
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/msn-pecan/msn-pecan-0.1.4.ebuild')
-rw-r--r--x11-plugins/msn-pecan/msn-pecan-0.1.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-plugins/msn-pecan/msn-pecan-0.1.4.ebuild b/x11-plugins/msn-pecan/msn-pecan-0.1.4.ebuild
new file mode 100644
index 000000000000..5534e4070df9
--- /dev/null
+++ b/x11-plugins/msn-pecan/msn-pecan-0.1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/msn-pecan-0.1.4.ebuild,v 1.1 2012/10/15 09:54:42 voyageur Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Alternative MSN protocol plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/msn-pecan/"
+
+SRC_URI="http://msn-pecan.googlecode.com/files/${P/_/-}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ sed -e "/^LDFLAGS/{s/$/ ${LDFLAGS}/;}" \
+ -e "/^CFLAGS/{s/$/ ${CFLAGS}/;}" -i Makefile \
+ || die "Flags sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README TODO
+}
+
+pkg_postinst() {
+ elog "Select the 'WLM' protocol to use this plugin"
+ einfo
+ elog "For more information (how to change personal message, add"
+ elog "missing emoticons, ...), please read:"
+ elog "http://code.google.com/p/msn-pecan/wiki/FAQ"
+}