summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-08 16:10:04 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-08 16:10:04 +0000
commit3d3971f6edf599e5413adb6730ec00c6e84276fd (patch)
tree92506063f04ab452789835a2d1dc9c9ce4ebcd94 /x11-plugins/pidgin-extprefs
parentFix deprecation warnings. (diff)
downloadgentoo-2-3d3971f6edf599e5413adb6730ec00c6e84276fd.tar.gz
gentoo-2-3d3971f6edf599e5413adb6730ec00c6e84276fd.tar.bz2
gentoo-2-3d3971f6edf599e5413adb6730ec00c6e84276fd.zip
QA on ebuild style, specially shortend description
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/pidgin-extprefs')
-rw-r--r--x11-plugins/pidgin-extprefs/ChangeLog8
-rw-r--r--x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7-r1.ebuild17
-rw-r--r--x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7.ebuild19
3 files changed, 19 insertions, 25 deletions
diff --git a/x11-plugins/pidgin-extprefs/ChangeLog b/x11-plugins/pidgin-extprefs/ChangeLog
index c6ad1f9091c9..d62670d2862c 100644
--- a/x11-plugins/pidgin-extprefs/ChangeLog
+++ b/x11-plugins/pidgin-extprefs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-extprefs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-extprefs/ChangeLog,v 1.14 2010/10/26 14:32:32 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-extprefs/ChangeLog,v 1.15 2011/01/08 16:10:04 jlec Exp $
+
+ 08 Jan 2011; Justin Lecher <jlec@gentoo.org> pidgin-extprefs-0.7.ebuild,
+ pidgin-extprefs-0.7-r1.ebuild:
+ QA on ebuild style, specially shortend description
26 Oct 2010; Jeroen Roovers <jer@gentoo.org>
pidgin-extprefs-0.7-r1.ebuild:
diff --git a/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7-r1.ebuild b/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7-r1.ebuild
index 27efeed20fa6..92e3b46e9404 100644
--- a/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7-r1.ebuild
+++ b/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7-r1.ebuild
@@ -1,28 +1,23 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7-r1.ebuild,v 1.6 2010/10/26 14:32:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7-r1.ebuild,v 1.7 2011/01/08 16:10:04 jlec Exp $
EAPI=2
-DESCRIPTION="Pidgin Extended Preferences is a plugin that takes advantage of existing pidgin functionality to provide preferences that are often desired but not are not considered worthy of inclusion in Pidgin itself."
-
+DESCRIPTION="Extra preferences that are desired but not are not considered worthy of inclusion in Pidgin itself"
HOMEPAGE="http://gaim-extprefs.sourceforge.net"
-
SRC_URI="mirror://sourceforge/gaim-extprefs/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="amd64 hppa ppc sparc x86"
-
IUSE=""
RDEPEND="net-im/pidgin[gtk]"
-
-DEPEND="dev-util/pkgconfig
+DEPEND="
+ dev-util/pkgconfig
${RDEPEND}"
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
}
diff --git a/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7.ebuild b/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7.ebuild
index 3dea9bc22464..97b0eaed0878 100644
--- a/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7.ebuild
+++ b/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7.ebuild
@@ -1,31 +1,26 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7.ebuild,v 1.9 2008/05/17 15:46:11 tester Exp $
-
-DESCRIPTION="Pidgin Extended Preferences is a plugin that takes advantage of existing pidgin functionality to provide preferences that are often desired but not are not considered worthy of inclusion in Pidgin itself."
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-extprefs/pidgin-extprefs-0.7.ebuild,v 1.10 2011/01/08 16:10:04 jlec Exp $
+DESCRIPTION="Extra preferences that are desired but not are not considered worthy of inclusion in Pidgin itself"
HOMEPAGE="http://gaim-extprefs.sourceforge.net"
-
SRC_URI="mirror://sourceforge/gaim-extprefs/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="amd64 hppa ppc sparc x86"
-
IUSE=""
RDEPEND="net-im/pidgin"
-
-DEPEND="dev-util/pkgconfig
+DEPEND="
+ dev-util/pkgconfig
${RDEPEND}"
src_compile() {
- econf || die "econf failed"
+ econf
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
}