summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-24 14:48:18 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-24 14:48:18 +0000
commit973d347f3834cd56d92d990cfc8a19c98fde5e18 (patch)
treeb251b1d9d24d3ea026ddfb48fb14d908684880e0 /x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild
parentMigrate changes from Gentoo Prefix overlay. KEYWORDS, change to EAPI3, add co... (diff)
downloadgentoo-2-973d347f3834cd56d92d990cfc8a19c98fde5e18.tar.gz
gentoo-2-973d347f3834cd56d92d990cfc8a19c98fde5e18.tar.bz2
gentoo-2-973d347f3834cd56d92d990cfc8a19c98fde5e18.zip
Initial commit for thinkhdaps
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild')
-rw-r--r--x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild b/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild
new file mode 100644
index 000000000000..03f5ec0f0704
--- /dev/null
+++ b/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild,v 1.1 2010/08/24 14:48:18 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND=2
+
+inherit base python
+
+DESCRIPTION="A PyGTK based HDAPS monitor"
+HOMEPAGE="http://thpani.at/projects/thinkhdaps/"
+SRC_URI="http://thpani.at/media/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/libgnome-python:2
+ dev-python/pygobject:2
+ dev-python/pygtk:2"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ econf --enable-desktop PYTHON=$(PYTHON -2 --absolute-path)
+}