summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-12-21 21:59:01 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-12-21 21:59:01 +0000
commita5ceaaf5f98ba18b0da66b461c8e051a5b7891db (patch)
treee7ab3f448da08dbb3208534c641f7f9f1deab3ce /x11-plugins/tomboy-reminder
parent- version bump to upstream stable (diff)
downloadgentoo-2-a5ceaaf5f98ba18b0da66b461c8e051a5b7891db.tar.gz
gentoo-2-a5ceaaf5f98ba18b0da66b461c8e051a5b7891db.tar.bz2
gentoo-2-a5ceaaf5f98ba18b0da66b461c8e051a5b7891db.zip
add patch to build using gmcs
(Portage version: 2.1.2_rc3-r9)
Diffstat (limited to 'x11-plugins/tomboy-reminder')
-rw-r--r--x11-plugins/tomboy-reminder/ChangeLog6
-rw-r--r--x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch27
-rw-r--r--x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild12
3 files changed, 42 insertions, 3 deletions
diff --git a/x11-plugins/tomboy-reminder/ChangeLog b/x11-plugins/tomboy-reminder/ChangeLog
index 1453cc61c2b1..2ef598d5560e 100644
--- a/x11-plugins/tomboy-reminder/ChangeLog
+++ b/x11-plugins/tomboy-reminder/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/tomboy-reminder
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/ChangeLog,v 1.2 2006/12/07 20:51:08 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/ChangeLog,v 1.3 2006/12/21 21:59:01 compnerd Exp $
+
+ 21 Dec 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/tomboy-reminder-0.9-mcs-to-gmcs.patch, tomboy-reminder-0.9.ebuild:
+ add patch to build using gmcs as it uses generics
07 Dec 2006; Saleem Abdulrasool <compnerd@gentoo.org>
tomboy-reminder-0.9.ebuild:
diff --git a/x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch b/x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch
new file mode 100644
index 000000000000..0040bff88ac5
--- /dev/null
+++ b/x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch
@@ -0,0 +1,27 @@
+--- src/Makefile.am 2006-12-21 09:50:16.000000000 -0600
++++ src/Makefile.am 2006-12-21 09:50:21.000000000 -0600
+@@ -1,5 +1,5 @@
+
+-CSC = mcs -debug
++CSC = gmcs -debug
+
+ TARGET_NAME = tomboy-reminder
+ TARGET = $(TARGET_NAME).dll
+--- configure.in 2006-12-21 09:50:32.000000000 -0600
++++ configure.in 2006-12-21 09:51:22.000000000 -0600
+@@ -5,11 +5,11 @@
+ AC_PROG_INSTALL
+
+ #
+-# Find mcs
++# Find gmcs
+ #
+-AC_PATH_PROG(MCS, mcs)
+-if test "x$MCS" = "x" ; then
+- AC_MSG_ERROR([Can't find "mcs", the mono compiler in your PATH])
++AC_PATH_PROG(GMCS, gmcs)
++if test "x$GMCS" = "x" ; then
++ AC_MSG_ERROR([Can't find "gmcs", the mono compiler in your PATH])
+ fi
+
+ #
diff --git a/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild b/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild
index a9a751d8c38c..86ea46c3f37e 100644
--- a/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild
+++ b/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild,v 1.2 2006/12/07 20:51:08 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild,v 1.3 2006/12/21 21:59:01 compnerd Exp $
-inherit mono eutils
+inherit autotools eutils mono
DESCRIPTION="Reminder Plugin for Tomboy"
HOMEPAGE="http://raphael.slinckx.net/blog/projects/tomboy-reminder-plugin/"
@@ -18,6 +18,14 @@ RDEPEND=">=dev-lang/mono-1.0
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.19"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.9-mcs-to-gmcs.patch
+ eautomake
+}
+
src_install() {
make DESTDIR="${D}" install || die "install failed"
dodoc README NEWS ChangeLog AUTHORS