summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-08-31 13:57:39 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-08-31 13:57:39 +0000
commitf5be8a0327a5ab693a1b95894efbf079a02109f5 (patch)
treeb812247abcde29454064cc44d22fdd0912f4c180 /x11-plugins/wmail/wmail-2.0-r1.ebuild
parenturi problems with valueclick. this should get tigger to stop bouncing. (Manif... (diff)
downloadgentoo-2-f5be8a0327a5ab693a1b95894efbf079a02109f5.tar.gz
gentoo-2-f5be8a0327a5ab693a1b95894efbf079a02109f5.tar.bz2
gentoo-2-f5be8a0327a5ab693a1b95894efbf079a02109f5.zip
Revision bump for x11-plugins/wmail-2.0, adding support for libdockapp-0.5.0. See #54580
Diffstat (limited to 'x11-plugins/wmail/wmail-2.0-r1.ebuild')
-rw-r--r--x11-plugins/wmail/wmail-2.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/wmail/wmail-2.0-r1.ebuild b/x11-plugins/wmail/wmail-2.0-r1.ebuild
new file mode 100644
index 000000000000..6edfe7fbbe9e
--- /dev/null
+++ b/x11-plugins/wmail/wmail-2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/wmail-2.0-r1.ebuild,v 1.1 2004/08/31 13:57:39 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Window Maker dock application showing incoming mail"
+SRC_URI="http://www.minet.uni-jena.de/~topical/sveng/wmail/${P}.tar.gz"
+HOMEPAGE="http://www.dockapps.org/file.php/id/70"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="virtual/libc
+ virtual/x11
+ >=x11-libs/libdockapp-0.5.0"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.support-libdockapp-0.5.0.patch
+}
+
+src_compile()
+{
+ econf --enable-delt-xpms || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install()
+{
+ dobin src/wmail
+ dodoc README wmailrc-sample
+}
+