summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-24 18:17:04 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-24 18:17:04 +0000
commit8487019a4846f82eb348aa58fb23b8cb6ca224c6 (patch)
tree7870f97526bd6d75f07853b2fcf7ac3a48e3a935 /x11-plugins/wmcube/wmcube-0.98.ebuild
parentthe new build of root-portal, a desktop interaction tool (diff)
downloadgentoo-2-8487019a4846f82eb348aa58fb23b8cb6ca224c6.tar.gz
gentoo-2-8487019a4846f82eb348aa58fb23b8cb6ca224c6.tar.bz2
gentoo-2-8487019a4846f82eb348aa58fb23b8cb6ca224c6.zip
Initial ebuild. See bug #5446
Diffstat (limited to 'x11-plugins/wmcube/wmcube-0.98.ebuild')
-rw-r--r--x11-plugins/wmcube/wmcube-0.98.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/wmcube/wmcube-0.98.ebuild b/x11-plugins/wmcube/wmcube-0.98.ebuild
new file mode 100644
index 000000000000..d96bd0f86327
--- /dev/null
+++ b/x11-plugins/wmcube/wmcube-0.98.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcube/wmcube-0.98.ebuild,v 1.1 2002/10/24 18:17:04 raker Exp $
+
+DESCRIPTION="a dockapp cpu monitor with spinning 3d objects"
+HOMEPAGE="http://boombox.campus.luth.se"
+SRC_URI="http://www.stud.ifi.uio.no/~steingrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+IUSE=""
+
+DEPEND="virtual/glibc
+ virtual/x11"
+
+S="${WORKDIR}/${P}/wmcube"
+
+src_compile() {
+
+ emake || die "parallel make failed"
+
+}
+
+src_install() {
+
+ dobin wmcube
+
+ cd ..
+ dodoc README CHANGES
+
+ SHARE=${DESTTREE}/share/wmcube
+ dodir ${SHARE}
+ insinto ${SHARE}
+ doins 3dObjects/*
+
+}
+