summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-06 21:01:20 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-06 21:01:20 +0000
commit34f9d7b4ffbb6223cb16502411706e39fe1c2bca (patch)
tree4f7aa4bf325f82a0bd2b6d9ce812f3b3ea572772 /x11-plugins/wmdate
parentcleanup (diff)
downloadgentoo-2-34f9d7b4ffbb6223cb16502411706e39fe1c2bca.tar.gz
gentoo-2-34f9d7b4ffbb6223cb16502411706e39fe1c2bca.tar.bz2
gentoo-2-34f9d7b4ffbb6223cb16502411706e39fe1c2bca.zip
Fix depends wrt #204546. Call xmkmf without -a since it's not needed. Drop false .desktop entry. Respect CC target.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'x11-plugins/wmdate')
-rw-r--r--x11-plugins/wmdate/ChangeLog9
-rw-r--r--x11-plugins/wmdate/files/wmdate.desktop9
-rw-r--r--x11-plugins/wmdate/wmdate-0.7.ebuild45
3 files changed, 29 insertions, 34 deletions
diff --git a/x11-plugins/wmdate/ChangeLog b/x11-plugins/wmdate/ChangeLog
index b31c44473975..a5b70f9bbf4b 100644
--- a/x11-plugins/wmdate/ChangeLog
+++ b/x11-plugins/wmdate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmdate
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdate/ChangeLog,v 1.10 2007/02/06 01:59:33 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdate/ChangeLog,v 1.11 2008/01/06 21:01:19 drac Exp $
+
+ 06 Jan 2008; Samuli Suominen <drac@gentoo.org> -files/wmdate.desktop,
+ wmdate-0.7.ebuild:
+ Fix depends wrt #204546. Call xmkmf without -a since it's not needed. Drop
+ false .desktop entry. Respect CC target.
06 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/x11-plugins/wmdate/files/wmdate.desktop b/x11-plugins/wmdate/files/wmdate.desktop
deleted file mode 100644
index 6866e667cf64..000000000000
--- a/x11-plugins/wmdate/files/wmdate.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=WmDate
-Comment=Dockable date-display utility for X11
-Comment[pl]=Dokowalny wyświetlacz daty dla X11
-Exec=wmdate
-Type=Application
-Encoding=UTF-8
-Terminal=0
-Categories=Application;Calendar;
diff --git a/x11-plugins/wmdate/wmdate-0.7.ebuild b/x11-plugins/wmdate/wmdate-0.7.ebuild
index 09f0c50232a7..15dde2af1d78 100644
--- a/x11-plugins/wmdate/wmdate-0.7.ebuild
+++ b/x11-plugins/wmdate/wmdate-0.7.ebuild
@@ -1,40 +1,39 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdate/wmdate-0.7.ebuild,v 1.9 2006/01/24 22:59:20 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdate/wmdate-0.7.ebuild,v 1.10 2008/01/06 21:01:19 drac Exp $
-inherit eutils
-
-IUSE=""
+inherit eutils toolchain-funcs
DESCRIPTION="yet another date-display dock application"
-SRC_URI="http://solfertje.student.utwente.nl/~dalroi/${PN}/files/${P}.tar.gz"
HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/applications.php"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/${PN}/files/${P}.tar.gz"
-DEPEND="x11-libs/libdockapp"
-
+LICENSE="as-is"
SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc ppc64 ~sparc amd64"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libdockapp
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake"
src_unpack() {
unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${PN}-ComplexProgramTargetNoMan.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
}
src_compile() {
- cd ${S}
- PATH="$PATH:/usr/X11R6/bin"
- xmkmf -a
- emake CDEBUGFLAGS="${CFLAGS}" || die "make failed"
+ xmkmf || die "xmkmf failed."
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ || die "emake failed."
}
src_install() {
- einstall DESTDIR=${D} BINDIR=/usr/bin || DIE "make install failed"
-
- dodoc README
-
- insinto /usr/share/applications
- doins ${FILESDIR}/${PN}.desktop
+ dobin ${PN}
+ dodoc Changelog README
}