summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:53:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:53:06 +0000
commit0cd3a0be8b3ed040c0381f4c7f83396b14ceef72 (patch)
tree2bf08404481801f0a1ae7e663c13fd732e8cf0bf /x11-plugins/wmdrawer
parentUse EAPI5 instead of EAPI1. (diff)
downloadgentoo-2-0cd3a0be8b3ed040c0381f4c7f83396b14ceef72.tar.gz
gentoo-2-0cd3a0be8b3ed040c0381f4c7f83396b14ceef72.tar.bz2
gentoo-2-0cd3a0be8b3ed040c0381f4c7f83396b14ceef72.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins/wmdrawer')
-rw-r--r--x11-plugins/wmdrawer/ChangeLog8
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild28
2 files changed, 16 insertions, 20 deletions
diff --git a/x11-plugins/wmdrawer/ChangeLog b/x11-plugins/wmdrawer/ChangeLog
index 88a85711ddec..1dd4ad8d6782 100644
--- a/x11-plugins/wmdrawer/ChangeLog
+++ b/x11-plugins/wmdrawer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmdrawer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/ChangeLog,v 1.24 2012/05/05 05:12:01 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/ChangeLog,v 1.25 2014/04/07 19:53:06 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmdrawer-0.10.5-r2.ebuild:
+ Use EAPI5 instead of EAPI1.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wmdrawer-0.10.5-r2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -104,4 +107,3 @@
03 Jun 2003; Brad Cowan <bcowan@gentoo.org> wmdrawer-0.9.15.ebuild:
Initial import. Thanks to Martin Schipany bug # 16223
-
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
index c3c53929e66d..18638565ac0a 100644
--- a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
@@ -1,44 +1,38 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.10 2012/05/05 05:12:01 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.11 2014/04/07 19:53:06 ssuominen Exp $
+EAPI=5
inherit eutils
-IUSE=""
DESCRIPTION="dockapp which provides a drawer (retractable button bar) to launch applications"
-SRC_URI="http://people.easter-eggs.org/~valos/wmdrawer/${P}.tar.gz"
HOMEPAGE="http://people.easter-eggs.org/~valos/wmdrawer/"
+SRC_URI="http://people.easter-eggs.org/~valos/wmdrawer/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack () {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gtk+-2.patch
# Honour Gentoo CFLAGS
sed -i -e "s|-O3|${CFLAGS}|" Makefile || die
-
# Fix LDFLAGS ordering per bug #248640
- sed -i 's/$(CC) $(LDFLAGS) -o $@ $(OBJS)/$(CC) -o $@ $(OBJS) $(LDFLAGS)/' Makefile || die
-
+ sed -i -e 's/$(CC) $(LDFLAGS) -o $@ $(OBJS)/$(CC) -o $@ $(OBJS) $(LDFLAGS)/' Makefile || die
# Do not auto-strip binaries
- sed -i 's/ strip $@//' Makefile || die
-
+ sed -i -e 's/ strip $@//' Makefile || die
# Honour Gentoo LDFLAGS
- sed -i 's/$(CC) -o/$(CC) $(REAL_LDFLAGS) -o/' Makefile || die
+ sed -i -e 's/$(CC) -o/$(CC) $(REAL_LDFLAGS) -o/' Makefile || die
}
src_compile() {
- emake REAL_LDFLAGS="${LDFLAGS}" || die "make failed"
+ emake REAL_LDFLAGS="${LDFLAGS}"
}
src_install() {