summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-08-27 09:15:47 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-08-27 09:15:47 +0000
commit9d173532bcbb433f5a314fddd7e6bf9baa351af3 (patch)
tree1d6df86fb4707dc20f76f3395ffdb6966b99f430 /x11-plugins/wmlife
parentold (diff)
downloadgentoo-2-9d173532bcbb433f5a314fddd7e6bf9baa351af3.tar.gz
gentoo-2-9d173532bcbb433f5a314fddd7e6bf9baa351af3.tar.bz2
gentoo-2-9d173532bcbb433f5a314fddd7e6bf9baa351af3.zip
Version bump and ebuild cleanup. Add sticky option, fix regression causing second window and disable GDK client-side rendering
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmlife')
-rw-r--r--x11-plugins/wmlife/ChangeLog8
-rw-r--r--x11-plugins/wmlife/wmlife-1.0.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-plugins/wmlife/ChangeLog b/x11-plugins/wmlife/ChangeLog
index bf8b0c4829e8..8d5e032be7a7 100644
--- a/x11-plugins/wmlife/ChangeLog
+++ b/x11-plugins/wmlife/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmlife
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/ChangeLog,v 1.4 2012/05/05 05:12:01 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/ChangeLog,v 1.5 2012/08/27 09:15:47 voyageur Exp $
+
+*wmlife-1.0.1 (27 Aug 2012)
+
+ 27 Aug 2012; Bernard Cafarelli <voyageur@gentoo.org> +wmlife-1.0.1.ebuild:
+ Version bump and ebuild cleanup. Add sticky option, fix regression causing
+ second window and disable GDK client-side rendering
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wmlife-1.0.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-plugins/wmlife/wmlife-1.0.1.ebuild b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
new file mode 100644
index 000000000000..62804b123bc0
--- /dev/null
+++ b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/wmlife-1.0.1.ebuild,v 1.1 2012/08/27 09:15:47 voyageur Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="dockapp running Conway's Game of Life (and program launcher)."
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmlife"
+SRC_URI="http://www.swanson.ukfsn.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/libgnomeui-2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.0-stringh.patch
+}
+
+src_configure() {
+ econf --enable-session
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+}