summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-29 13:26:03 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-29 13:26:03 +0000
commit63b8eb004aed91e09842a98d922bd082cb50e74b (patch)
tree0cd85ab5b37da7d7d5a4ba9672f4656e21c9c00b /x11-plugins/wmload
parentold (diff)
downloadgentoo-2-63b8eb004aed91e09842a98d922bd082cb50e74b.tar.gz
gentoo-2-63b8eb004aed91e09842a98d922bd082cb50e74b.tar.bz2
gentoo-2-63b8eb004aed91e09842a98d922bd082cb50e74b.zip
quoting
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc3 x86_64)
Diffstat (limited to 'x11-plugins/wmload')
-rw-r--r--x11-plugins/wmload/wmload-0.9.2.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/x11-plugins/wmload/wmload-0.9.2.ebuild b/x11-plugins/wmload/wmload-0.9.2.ebuild
index 172c47458d77..f0d6f477bbc6 100644
--- a/x11-plugins/wmload/wmload-0.9.2.ebuild
+++ b/x11-plugins/wmload/wmload-0.9.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmload/wmload-0.9.2.ebuild,v 1.8 2007/07/22 04:55:45 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmload/wmload-0.9.2.ebuild,v 1.9 2008/06/29 13:26:03 drac Exp $
inherit eutils
@@ -24,23 +24,20 @@ KEYWORDS="~amd64 ppc ~sparc x86"
src_unpack() {
unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${PN}-ComplexProgramTargetNoMan.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
}
src_compile() {
- cd ${S}
- PATH="$PATH:/usr/X11R6/bin"
- xmkmf || die "xmkmf failed"
- emake CDEBUGFLAGS="${CFLAGS}" || die "Compilation failed"
+ xmkmf || die "xmkmf failed."
+ emake CDEBUGFLAGS="${CFLAGS}" || die "emake failed."
}
src_install() {
- einstall DESTDIR=${D} BINDIR=/usr/bin || die "Installation failed"
+ einstall DESTDIR="${D}" BINDIR=/usr/bin || die "einstall failed."
dodoc README
insinto /usr/share/applications
- doins ${FILESDIR}/${PN}.desktop
+ doins "${FILESDIR}"/${PN}.desktop
}