summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-08-31 13:52:38 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-08-31 13:52:38 +0000
commit4e623de298edd774cee98c027eade5f279f9932d (patch)
tree0e416746c9bb94feb29eb6d378bc3e302e8bc031 /x11-plugins/wmmaiload
parent Honour Gentoo LDFLAGS. Closes bug #334005. (diff)
downloadgentoo-2-4e623de298edd774cee98c027eade5f279f9932d.tar.gz
gentoo-2-4e623de298edd774cee98c027eade5f279f9932d.tar.bz2
gentoo-2-4e623de298edd774cee98c027eade5f279f9932d.zip
Fixed nasty bug the wmmaiload compilation fails and a *binary version present in the tarball* is installed.
Fixes bug #334001. (Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmmaiload')
-rw-r--r--x11-plugins/wmmaiload/ChangeLog9
-rw-r--r--x11-plugins/wmmaiload/files/wmmaiload-2.2.1-checkthread.patch17
-rw-r--r--x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild5
3 files changed, 27 insertions, 4 deletions
diff --git a/x11-plugins/wmmaiload/ChangeLog b/x11-plugins/wmmaiload/ChangeLog
index 18e2e1a71e53..da95649ce8fb 100644
--- a/x11-plugins/wmmaiload/ChangeLog
+++ b/x11-plugins/wmmaiload/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmmaiload
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/ChangeLog,v 1.32 2009/06/04 00:21:21 tcunha Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/ChangeLog,v 1.33 2010/08/31 13:52:38 s4t4n Exp $
+
+ 31 Aug 2010; Michele Noberasco <s4t4n@gentoo.org> wmmaiload-2.2.1-r1.ebuild,
+ files/wmmaiload-2.2.1-checkthread.patch:
+ Fixed nasty bug the wmmaiload compilation fails and a *binary version present in the tarball* is installed.
+ Fixes bug #334001.
04 Jun 2009; Tiago Cunha <tcunha@gentoo.org> wmmaiload-2.2.1-r1.ebuild:
stable sparc, bug 215651
diff --git a/x11-plugins/wmmaiload/files/wmmaiload-2.2.1-checkthread.patch b/x11-plugins/wmmaiload/files/wmmaiload-2.2.1-checkthread.patch
new file mode 100644
index 000000000000..941cb03ae3bb
--- /dev/null
+++ b/x11-plugins/wmmaiload/files/wmmaiload-2.2.1-checkthread.patch
@@ -0,0 +1,17 @@
+--- wmmaiload-2.2.1.orig/wmmaiload/checkthread.c 2010-08-31 15:43:37.000000000 +0200
++++ wmmaiload-2.2.1/wmmaiload/checkthread.c.new 2010-08-31 15:43:46.000000000 +0200
+@@ -101,14 +101,6 @@
+ #endif /* HAVE_MH */
+
+
+-#ifndef _GNU_SOURCE
+-int isblank(int c)
+-{
+- return (c == ' ' || c == '\t');
+-}
+-#endif
+-
+-
+ #ifdef HAVE_MBOX
+ static Bool check_mbox(MailBox *box, time_t now)
+ {
diff --git a/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild b/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
index cadf371b0b84..7c2b35339ca8 100644
--- a/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
+++ b/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild,v 1.6 2009/06/04 00:21:21 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild,v 1.7 2010/08/31 13:52:38 s4t4n Exp $
inherit eutils toolchain-funcs
@@ -22,6 +22,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gtk.patch
+ epatch "${FILESDIR}"/${P}-checkthread.patch
}
src_compile() {