summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-03 15:03:16 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-03 15:03:16 +0000
commitdc3e6d6b6cda71502af214f228f5c098cd45aba3 (patch)
treee2062fa2efef0cbf722942a3fc44ae697f06c0d7 /x11-plugins/wmmemmon
parentSecurity update (diff)
downloadgentoo-2-dc3e6d6b6cda71502af214f228f5c098cd45aba3.tar.gz
gentoo-2-dc3e6d6b6cda71502af214f228f5c098cd45aba3.tar.bz2
gentoo-2-dc3e6d6b6cda71502af214f228f5c098cd45aba3.zip
Updated wmnet with "... || die "blah"" constructs. Bug #1236 closed.
Added wmmemmon to x11-plugins. Closes bug #1324
Diffstat (limited to 'x11-plugins/wmmemmon')
-rw-r--r--x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.01
-rw-r--r--x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.0 b/x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.0
new file mode 100644
index 000000000000..f9ffe2e476da
--- /dev/null
+++ b/x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.0
@@ -0,0 +1 @@
+MD5 25f45b3fe8c18a6fc4da9f00d71cd94b wmmemmon-0.7.0.tar.gz 126188
diff --git a/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild b/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild
new file mode 100644
index 000000000000..2eb39af57d62
--- /dev/null
+++ b/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild,v 1.1 2002/10/03 15:03:16 raker Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A program to monitor memory/swap usages."
+SRC_URI="http://www.sh.rim.or.jp/~ssato/src/${P}.tar.gz"
+HOMEPAGE="http://www.sh.rim.or.jp/~ssato/dockapp/index.shtml#wmmemmon"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+
+DEPEND="virtual/glibc x11-base/xfree"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ econf || die "configure failed"
+
+ emake || die "parallel make failed"
+
+}
+
+src_install () {
+
+ einstall || die "make install failed"
+
+ doman doc/wmmemmon.1
+
+ dodoc AUTHORS THANKS TODO Changelog README
+
+ dobin src/wmmemmon
+
+}
+