summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-19 08:13:38 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-19 08:13:38 +0000
commit39c37c09c3cd8b5504d01853abd5c9e3811f5c91 (patch)
tree2c5d68cbd0d54db0c2224e3391c0230b77b21ff7 /x11-plugins/wmrecord/wmrecord-1.0.5.3.ebuild
parentInitial import of x11-plugins/wmgrabimage, version 0.72. Closes #54945 (Manif... (diff)
downloadgentoo-2-39c37c09c3cd8b5504d01853abd5c9e3811f5c91.tar.gz
gentoo-2-39c37c09c3cd8b5504d01853abd5c9e3811f5c91.tar.bz2
gentoo-2-39c37c09c3cd8b5504d01853abd5c9e3811f5c91.zip
Initial import of x11-plugins/wmrecord, version 1.0.5.3. Closes #54946
Diffstat (limited to 'x11-plugins/wmrecord/wmrecord-1.0.5.3.ebuild')
-rw-r--r--x11-plugins/wmrecord/wmrecord-1.0.5.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmrecord/wmrecord-1.0.5.3.ebuild b/x11-plugins/wmrecord/wmrecord-1.0.5.3.ebuild
new file mode 100644
index 000000000000..ade1b2680b6e
--- /dev/null
+++ b/x11-plugins/wmrecord/wmrecord-1.0.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmrecord/wmrecord-1.0.5.3.ebuild,v 1.1 2004/07/19 08:13:38 s4t4n Exp $
+
+IUSE=""
+
+DESCRIPTION="A Dockable General Purpose Recording Utility"
+SRC_URI="http://ret009t0.eresmas.net/other_software/wmrecord/${PN}-1.0.5_20040218_0029.tgz"
+HOMEPAGE="http://ret009t0.eresmas.net/other_software/wmrecord/"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${PN}-1.0.5
+
+src_compile()
+{
+ emake CFLAGS="${CFLAGS} -Wall" || die "make failed"
+}
+
+src_install()
+{
+ dodir /usr/bin
+ dodir /usr/share/man
+ einstall BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man" || die "make install failed"
+ prepallman
+
+ dodoc Changelog README TODO
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}