summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-03 21:54:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-03 21:54:59 +0000
commit72b1181a0e66056ccc28d02a66392955d234b3b2 (patch)
tree17dc3a988bfb80e3569bdada3918ee36bca61ec1 /x11-plugins/wmxkb
parentPin dependencies to appropriate slots. (diff)
downloadgentoo-2-72b1181a0e66056ccc28d02a66392955d234b3b2.tar.gz
gentoo-2-72b1181a0e66056ccc28d02a66392955d234b3b2.tar.bz2
gentoo-2-72b1181a0e66056ccc28d02a66392955d234b3b2.zip
Fix file collision with nvclock wrt #350496 by Joost Ruis. rewrite the ebuild while at it
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmxkb')
-rw-r--r--x11-plugins/wmxkb/ChangeLog7
-rw-r--r--x11-plugins/wmxkb/wmxkb-1.2.2.ebuild29
2 files changed, 21 insertions, 15 deletions
diff --git a/x11-plugins/wmxkb/ChangeLog b/x11-plugins/wmxkb/ChangeLog
index 63cfd7ec57a5..8fbcf0eba58e 100644
--- a/x11-plugins/wmxkb/ChangeLog
+++ b/x11-plugins/wmxkb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmxkb
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmxkb/ChangeLog,v 1.12 2010/09/09 10:33:35 s4t4n Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmxkb/ChangeLog,v 1.13 2011/01/03 21:54:59 ssuominen Exp $
+
+ 03 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> wmxkb-1.2.2.ebuild:
+ Fix file collision with nvclock wrt #350496 by Joost Ruis.
09 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> wmxkb-1.2.2.ebuild:
Honour Gentoo LDFLAGS, see bug #336528.
diff --git a/x11-plugins/wmxkb/wmxkb-1.2.2.ebuild b/x11-plugins/wmxkb/wmxkb-1.2.2.ebuild
index 755cff2c7c6f..ef2a2c94371b 100644
--- a/x11-plugins/wmxkb/wmxkb-1.2.2.ebuild
+++ b/x11-plugins/wmxkb/wmxkb-1.2.2.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmxkb/wmxkb-1.2.2.ebuild,v 1.9 2010/09/09 10:33:35 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmxkb/wmxkb-1.2.2.ebuild,v 1.10 2011/01/03 21:54:59 ssuominen Exp $
EAPI=2
-IUSE=""
+inherit toolchain-funcs
DESCRIPTION="Dockable keyboard layout switcher for Window Maker"
HOMEPAGE="http://wmalms.tripod.com/#WMXKB"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXt
@@ -23,17 +24,19 @@ DEPEND="${RDEPEND}
x11-proto/inputproto"
src_prepare() {
- #Honour Gentoo LDFLAGS, see bug #336528.
- sed -ie "s/\$(LD) -o/\$(LD) \$(LDFLAGS) -o/" Makefile.in
+ sed -i -e 's:$(LD) -o:$(CC) $(LDFLAGS) -o:' Makefile.in || die #336528
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
}
-src_install () {
- make DESTDIR="${D}" BINDIR="${D}/usr/bin" DOCDIR="${D}/usr/share/doc" DATADIR="${D}/usr/share" install
+src_install() {
+ dobin wmxkb || die #242188
- #install binary by hand per bug #242188
- dobin wmxkb
+ insinto /usr/share/pixmaps/wmxkb
+ doins pixmaps/*.xpm || die
- dodoc README
- cd "${WORKDIR}/${P}/doc"
- dodoc manual_body.html manual_title.html manual.book
+ dodoc CHANGES README || die #350496
+ dohtml doc/*.html || die
}