summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-12-02 10:51:54 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-12-02 10:51:54 +0000
commit3439c36065e3d9c2a53ed3889be066dba5850024 (patch)
tree1f154c9df0add3da18469224f8bb36d33f35cc2b /x11-plugins
parentFix LDFLAGS ordering. Fixes bug #248641. (diff)
downloadgentoo-2-3439c36065e3d9c2a53ed3889be066dba5850024.tar.gz
gentoo-2-3439c36065e3d9c2a53ed3889be066dba5850024.tar.bz2
gentoo-2-3439c36065e3d9c2a53ed3889be066dba5850024.zip
Fix LDFLAGS ordering per bug #248640. Some generic QA fixes.
(Portage version: 2.1.4.5)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmdrawer/ChangeLog5
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/x11-plugins/wmdrawer/ChangeLog b/x11-plugins/wmdrawer/ChangeLog
index 4912b446a6d1..cb814f5d6e93 100644
--- a/x11-plugins/wmdrawer/ChangeLog
+++ b/x11-plugins/wmdrawer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmdrawer
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/ChangeLog,v 1.20 2008/01/12 01:13:56 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/ChangeLog,v 1.21 2008/12/02 10:51:54 s4t4n Exp $
+
+ 02 Dec 2008; Michele Noberasco <s4t4n@gentoo.org> wmdrawer-0.10.5-r2.ebuild:
+ Fix LDFLAGS ordering per bug #248640. Some generic QA fixes.
12 Jan 2008; Santiago M. Mola <coldwind@gentoo.org>
wmdrawer-0.10.5-r2.ebuild:
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
index 2c5f69738e56..f611ff24d83f 100644
--- a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.6 2008/01/12 01:13:56 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.7 2008/12/02 10:51:54 s4t4n Exp $
inherit eutils
@@ -24,6 +24,12 @@ src_unpack () {
# Honour Gentoo CFLAGS
sed -i -e "s|-O3|${CFLAGS}|" Makefile || die
+
+ # Fix LDFLAGS ordering per bug #248640
+ sed -i 's/$(CC) $(LDFLAGS) -o $@ $(OBJS)/$(CC) -o $@ $(OBJS) $(LDFLAGS)/' Makefile || die
+
+ # Do not auto-strip binaries
+ sed -i 's/ strip $@//' Makefile || die
}
src_install() {