summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:44:27 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:44:27 +0000
commit4fc200d7c8d006435d2ed4b61e5c56ff058ed252 (patch)
tree3b21b03ce6d8b0a3d11e744392f36ef934562d11 /x11-plugins
parentnew viewer for X (diff)
downloadgentoo-2-4fc200d7c8d006435d2ed4b61e5c56ff058ed252.tar.gz
gentoo-2-4fc200d7c8d006435d2ed4b61e5c56ff058ed252.tar.bz2
gentoo-2-4fc200d7c8d006435d2ed4b61e5c56ff058ed252.zip
soundscope visualiser plugin
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellmss/ChangeLog12
-rw-r--r--x11-plugins/gkrellmss/files/digest-gkrellmss-2.31
-rw-r--r--x11-plugins/gkrellmss/files/gkrellmss-patch-2.3.diff22
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.3.ebuild41
4 files changed, 76 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmss/ChangeLog b/x11-plugins/gkrellmss/ChangeLog
new file mode 100644
index 000000000000..b1a30748beff
--- /dev/null
+++ b/x11-plugins/gkrellmss/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-plugins/gkrelmss
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/ChangeLog,v 1.1 2003/02/12 10:44:27 seemant Exp $
+
+*gkrellmss-2.3 (12 Feb 2003)
+
+ 12 Feb 2003; Seemant Kulleen <seemant@gentoo.org> ChangeLog
+ gkrellmss-2.3.ebuild files/gkrellmss-2.3-gentoo.diff
+ files/digest-gkrellmss-2.3 :
+
+ New sound scope plugin which uses EsounD, for GKrellM2. Submitted by:
+ Alex Revo <accessps@yahoo.com> in bug #13692.
diff --git a/x11-plugins/gkrellmss/files/digest-gkrellmss-2.3 b/x11-plugins/gkrellmss/files/digest-gkrellmss-2.3
new file mode 100644
index 000000000000..e0255ee52706
--- /dev/null
+++ b/x11-plugins/gkrellmss/files/digest-gkrellmss-2.3
@@ -0,0 +1 @@
+MD5 457a85c28f049ef0787c842b5494ece0 gkrellmss-2.3.tar.gz 24398
diff --git a/x11-plugins/gkrellmss/files/gkrellmss-patch-2.3.diff b/x11-plugins/gkrellmss/files/gkrellmss-patch-2.3.diff
new file mode 100644
index 000000000000..3115c1e31f86
--- /dev/null
+++ b/x11-plugins/gkrellmss/files/gkrellmss-patch-2.3.diff
@@ -0,0 +1,22 @@
+--- src/Makefile.orig 2002-10-26 20:48:59.000000000 -0700
++++ src/Makefile 2003-01-10 19:24:22.000000000 -0700
+@@ -16,7 +16,7 @@
+
+ FFTW_LIB_DIR ?=
+
+-FFTW_LIB = $(FFTW_LIB_DIR) -lrfftw -lfftw
++FFTW_LIB = $(FFTW_LIB_DIR) -ldrfftw -ldfftw
+
+ FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(SD_INCLUDE)
+ LIBS = $(GTK_LIB) $(SD_LIB) $(FFTW_LIB) -lm
+--- src/gkrellmss.h.orig 2002-11-25 12:44:25.000000000 -0700
++++ src/gkrellmss.h 2003-01-10 19:23:35.000000000 -0700
+@@ -22,7 +22,7 @@
+
+ #include <gkrellm2/gkrellm.h>
+ #include <math.h>
+-#include <rfftw.h>
++#include <drfftw.h>
+
+
+ #if !defined(GKRELLM_VERSION_MAJOR) || (GKRELLM_VERSION_MAJOR<2)
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild
new file mode 100644
index 000000000000..36f58d579660
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild,v 1.1 2003/02/12 10:44:27 seemant Exp $
+
+inherit eutils
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://gkrellm.net/gkrellmss/gkrellmss.html"
+SRC_URI="http://gkrellm.net/gkrellmss/${P}.tar.gz"
+
+DEPEND="=app-admin/gkrellm-2*
+ dev-libs/fftw
+ media-sound/esound"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${FILESDIR}/gkrellmss-patch-2.3.diff
+}
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="${myconf} enable_nls=1"
+
+ emake ${myconf} || die
+}
+
+src_install () {
+ exeinto /usr/lib/gkrellm2/plugins
+ doexe src/gkrellmss.so
+ dodoc README Changelog Themes
+}