summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2005-11-10 10:08:33 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2005-11-10 10:08:33 +0000
commit92c5d4b4abe282ebdbe716a84dc1d8217cca8188 (patch)
tree49d3dbb22e9913f157cf2e68405bdb0ac0c261b8 /x11-plugins
parentTemporarily removed madwifi support until upstream can provide a working vers... (diff)
downloadgentoo-2-92c5d4b4abe282ebdbe716a84dc1d8217cca8188.tar.gz
gentoo-2-92c5d4b4abe282ebdbe716a84dc1d8217cca8188.tar.bz2
gentoo-2-92c5d4b4abe282ebdbe716a84dc1d8217cca8188.zip
Make use of built_with_use() (from eutils eclass) to fail if imlib2 is not compiled with 'X' USE flag enabled.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmhdplop/ChangeLog6
-rw-r--r--x11-plugins/wmhdplop/Manifest2
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild10
3 files changed, 11 insertions, 7 deletions
diff --git a/x11-plugins/wmhdplop/ChangeLog b/x11-plugins/wmhdplop/ChangeLog
index a2ce6f226cf8..27c483346dc9 100644
--- a/x11-plugins/wmhdplop/ChangeLog
+++ b/x11-plugins/wmhdplop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmhdplop
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.7 2005/11/08 08:55:51 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.8 2005/11/10 10:08:33 s4t4n Exp $
+
+ 10 Nov 2005; Michele Noberasco <s4t4n@gentoo.org> wmhdplop-0.9.7.ebuild:
+ Make use of built_with_use() (from eutils eclass) to fail if imlib2
+ is not compiled with 'X' USE flag enabled.
08 Nov 2005; Michele Noberasco <s4t4n@gentoo.org> wmhdplop-0.9.7.ebuild:
Warn the user if 'X' USE flag is not set, as this package needs imlib2
diff --git a/x11-plugins/wmhdplop/Manifest b/x11-plugins/wmhdplop/Manifest
index 033fc8b1adf8..53bd8a582d48 100644
--- a/x11-plugins/wmhdplop/Manifest
+++ b/x11-plugins/wmhdplop/Manifest
@@ -1,4 +1,4 @@
-MD5 53f08a69f1aa6696d1717e1b250a5f13 wmhdplop-0.9.7.ebuild 1328
+MD5 97c45b2a02c67d725266850d893e0644 wmhdplop-0.9.7.ebuild 1345
MD5 5231cdc49dc28427d9814a72ae1fb05d ChangeLog 1120
MD5 62ba71d3b2fa785a4cbd5d47fdbd0eb6 metadata.xml 165
MD5 0a55dceead9ad7a2f7205718807cc4df files/digest-wmhdplop-0.9.7 66
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild
index b6062d3a92b5..2808da2086ad 100644
--- a/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild,v 1.3 2005/11/08 08:55:51 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild,v 1.4 2005/11/10 10:08:33 s4t4n Exp $
inherit eutils
@@ -26,12 +26,12 @@ src_unpack()
# Honour Gentoo CFLAGS, but retain some the package author chose himself
epatch ${FILESDIR}/${PN}-cflags.patch
- if ! use X; then
+ if ! built_with_use imlib2 X; then
echo
- ewarn "This package depends on media-libs/imlib2, which needs"
- ewarn "to be compiled with 'X' USE flag enabled..."
+ eerror "This package depends on media-libs/imlib2, which needs"
+ eerror "to be compiled with 'X' USE flag enabled..."
echo
- epause
+ die
fi
}