summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-09-01 07:16:26 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-09-01 07:16:26 +0000
commitc950ef53b9a6ddc07ebad36000a273bb91766961 (patch)
treea5587f0284f595d8eab01f68274cd5d156a176f7 /x11-plugins
parentRespect LDFLAGS. Bug #335469 (diff)
downloadgentoo-2-c950ef53b9a6ddc07ebad36000a273bb91766961.tar.gz
gentoo-2-c950ef53b9a6ddc07ebad36000a273bb91766961.tar.bz2
gentoo-2-c950ef53b9a6ddc07ebad36000a273bb91766961.zip
Honour Gentoo LDFLAGS. Closes bug #335425.
Removed old Makedile patch relying on sed instead. (Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmbio/ChangeLog7
-rw-r--r--x11-plugins/wmbio/files/wmbio-Makefile.patch17
-rw-r--r--x11-plugins/wmbio/wmbio-1.02.ebuild7
3 files changed, 11 insertions, 20 deletions
diff --git a/x11-plugins/wmbio/ChangeLog b/x11-plugins/wmbio/ChangeLog
index 3dd08ce0c211..8a5f249bcfe3 100644
--- a/x11-plugins/wmbio/ChangeLog
+++ b/x11-plugins/wmbio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmbio
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbio/ChangeLog,v 1.15 2010/02/09 15:00:21 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbio/ChangeLog,v 1.16 2010/09/01 07:16:26 s4t4n Exp $
+
+ 01 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> wmbio-1.02.ebuild,
+ -files/wmbio-Makefile.patch:
+ Honour Gentoo LDFLAGS. Closes bug #335425.
+ Removed old Makedile patch relying on sed instead.
09 Feb 2010; Ben de Groot <yngwin@gentoo.org> wmbio-1.02.ebuild:
Fix typo (bug 299547). Migrate to eapi-2.
diff --git a/x11-plugins/wmbio/files/wmbio-Makefile.patch b/x11-plugins/wmbio/files/wmbio-Makefile.patch
deleted file mode 100644
index a2ad498fb8f3..000000000000
--- a/x11-plugins/wmbio/files/wmbio-Makefile.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile 2004-08-23 21:27:12.839943656 +0200
-+++ Makefile 2004-08-23 21:27:44.224172528 +0200
-@@ -3,12 +3,12 @@
- OBJS = wmbio.o wmgeneral.o
-
- .c.o:
-- cc -c -g -O2 -Wall $< -o $*.o
-+ cc -c ${CFLAGS} -Wall $< -o $*.o
-
- all: wmbio
-
- wmbio: $(OBJS)
-- cc -o wmbio $^ $(LIBDIR) $(LIBS)
-+ cc -o wmbio $^ ${CFLAGS} $(LIBDIR) $(LIBS)
-
- clean:
- for i in $(OBJS) ; do \
diff --git a/x11-plugins/wmbio/wmbio-1.02.ebuild b/x11-plugins/wmbio/wmbio-1.02.ebuild
index 77a62dd287ee..5cb14e3db633 100644
--- a/x11-plugins/wmbio/wmbio-1.02.ebuild
+++ b/x11-plugins/wmbio/wmbio-1.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbio/wmbio-1.02.ebuild,v 1.11 2010/02/09 15:00:21 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbio/wmbio-1.02.ebuild,v 1.12 2010/09/01 07:16:26 s4t4n Exp $
EAPI=2
inherit eutils
@@ -24,7 +24,10 @@ S=${WORKDIR}/${P}/src
src_prepare() {
# Honour Gentoo CFLAGS
- epatch "${FILESDIR}"/${PN}-Makefile.patch
+ sed -i "s/-g -O2/\$(CFLAGS)/" Makefile
+
+ # Honour Gentoo LDFLAGS
+ sed -i "s/-o wmbio/\$(LDFLAGS) -o wmbio/" Makefile
}
src_compile() {