summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-06-14 16:31:15 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-06-14 16:31:15 +0000
commitce7c9e1a659b826fbc2e6f65d89440c2c574f3ea (patch)
tree505e24f969c99921fb3b5ac5fa5ffe57b36a684a /x11-plugins
parentAdd games-strategy/openxcom-1.0.0, bug #470188. Thanks to Azamat H. Hackimov ... (diff)
downloadgentoo-2-ce7c9e1a659b826fbc2e6f65d89440c2c574f3ea.tar.gz
gentoo-2-ce7c9e1a659b826fbc2e6f65d89440c2c574f3ea.tar.bz2
gentoo-2-ce7c9e1a659b826fbc2e6f65d89440c2c574f3ea.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-sipe/ChangeLog7
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.18.2.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-sipe/ChangeLog b/x11-plugins/pidgin-sipe/ChangeLog
index f2771db97286..b478b9ee8839 100644
--- a/x11-plugins/pidgin-sipe/ChangeLog
+++ b/x11-plugins/pidgin-sipe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/pidgin-sipe
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.30 2014/05/10 09:11:26 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.31 2014/06/14 16:31:15 mrueg Exp $
+
+*pidgin-sipe-1.18.2 (14 Jun 2014)
+
+ 14 Jun 2014; Manuel Rüger <mrueg@gentoo.org> +pidgin-sipe-1.18.2.ebuild:
+ Version bump.
*pidgin-sipe-1.18.1 (10 May 2014)
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.18.2.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.18.2.ebuild
new file mode 100644
index 000000000000..b89219527671
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.18.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/pidgin-sipe-1.18.2.ebuild,v 1.1 2014/06/14 16:31:15 mrueg Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug kerberos ocs2005-message-hack openssl telepathy voice"
+
+RDEPEND=">=dev-libs/gmime-2.4.16
+ dev-libs/libxml2
+ openssl? ( dev-libs/openssl )
+ !openssl? ( dev-libs/nss )
+ kerberos? ( virtual/krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer:0.10
+ >=net-im/pidgin-2.8.0
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0:2
+ net-im/pidgin
+ )
+ telepathy? (
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.28:2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+
+DEPEND="dev-util/intltool
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ $(use_enable telepathy) \
+ $(use_enable debug) \
+ $(use_enable ocs2005-message-hack) \
+ $(use_with kerberos krb5) \
+ $(use_with voice vv) \
+ $(use_enable !openssl nss) \
+ $(use_enable openssl)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}