summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-01-07 04:35:15 +0000
committerOlivier Crête <tester@gentoo.org>2008-01-07 04:35:15 +0000
commitd5a5889c96d4534bce221160849e7ad4cb2ee9c8 (patch)
treea1edaf1170549d4999b15ef2b297c88fd11ba714 /x11-plugins
parentRemove extra tabs (diff)
downloadgentoo-2-d5a5889c96d4534bce221160849e7ad4cb2ee9c8.tar.gz
gentoo-2-d5a5889c96d4534bce221160849e7ad4cb2ee9c8.tar.bz2
gentoo-2-d5a5889c96d4534bce221160849e7ad4cb2ee9c8.zip
Add dep on gtk (and check that pidgin has it too)
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-libnotify/ChangeLog8
-rw-r--r--x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13-r1.ebuild17
-rw-r--r--x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13.ebuild17
3 files changed, 30 insertions, 12 deletions
diff --git a/x11-plugins/pidgin-libnotify/ChangeLog b/x11-plugins/pidgin-libnotify/ChangeLog
index fdc5536b3498..32f62095357e 100644
--- a/x11-plugins/pidgin-libnotify/ChangeLog
+++ b/x11-plugins/pidgin-libnotify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-libnotify
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/ChangeLog,v 1.7 2007/10/26 01:46:23 tester Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/ChangeLog,v 1.8 2008/01/07 04:35:15 tester Exp $
+
+ 07 Jan 2008; <tester@gentoo.org> pidgin-libnotify-0.13.ebuild,
+ pidgin-libnotify-0.13-r1.ebuild:
+ Add dep on gtk (and check that pidgin has it too)
*pidgin-libnotify-0.13-r1 (26 Oct 2007)
diff --git a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13-r1.ebuild b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13-r1.ebuild
index d39d7cb672a0..cb09c2758865 100644
--- a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13-r1.ebuild
+++ b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13-r1.ebuild,v 1.2 2007/10/26 19:09:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13-r1.ebuild,v 1.3 2008/01/07 04:35:15 tester Exp $
inherit eutils
@@ -13,9 +13,16 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="nls debug"
-DEPEND=">=x11-libs/libnotify-0.3.2"
+DEPEND=">=x11-libs/libnotify-0.3.2
+ net-im/pidgin
+ >=x11-libs/gtk+-2"
-RDEPEND="net-im/pidgin ${DEPEND}"
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
src_unpack() {
unpack ${A}
@@ -35,6 +42,6 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION
}
diff --git a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13.ebuild b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13.ebuild
index e0986c54e6f0..4a976aa610a9 100644
--- a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13.ebuild
+++ b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13.ebuild,v 1.5 2007/08/28 14:51:03 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.13.ebuild,v 1.6 2008/01/07 04:35:15 tester Exp $
DESCRIPTION="pidgin-libnotify provides popups for pidgin via a libnotify interface"
HOMEPAGE="http://gaim-libnotify.sourceforge.net/"
@@ -11,9 +11,16 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc x86"
IUSE="nls debug"
-DEPEND=">=x11-libs/libnotify-0.3.2"
+DEPEND=">=x11-libs/libnotify-0.3.2
+ net-im/pidgin
+ >=x11-libs/gtk+-2"
-RDEPEND="net-im/pidgin ${DEPEND}"
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
src_compile() {
local myconf
@@ -27,6 +34,6 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION
}