summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-17 00:13:25 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-17 00:13:25 +0000
commite82cb26c66234b43212ee7c720a7210a5a1b4df8 (patch)
tree6ad8c50f650c7bebfb83a454b802f25601c4a8ee /x11-plugins
parentold (diff)
downloadgentoo-2-e82cb26c66234b43212ee7c720a7210a5a1b4df8.tar.gz
gentoo-2-e82cb26c66234b43212ee7c720a7210a5a1b4df8.tar.bz2
gentoo-2-e82cb26c66234b43212ee7c720a7210a5a1b4df8.zip
Version bump.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmhdplop/ChangeLog9
-rw-r--r--x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.93
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.9.ebuild51
3 files changed, 61 insertions, 2 deletions
diff --git a/x11-plugins/wmhdplop/ChangeLog b/x11-plugins/wmhdplop/ChangeLog
index de62d8b37a15..0e968b2ebefe 100644
--- a/x11-plugins/wmhdplop/ChangeLog
+++ b/x11-plugins/wmhdplop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmhdplop
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.12 2007/07/22 05:04:45 dberkholz Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.13 2008/01/17 00:13:25 drac Exp $
+
+*wmhdplop-0.9.9 (17 Jan 2008)
+
+ 17 Jan 2008; Samuli Suominen <drac@gentoo.org> +wmhdplop-0.9.9.ebuild:
+ Version bump.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
wmhdplop-0.9.7-r1.ebuild:
diff --git a/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.9 b/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.9
new file mode 100644
index 000000000000..6f2701c70efd
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.9
@@ -0,0 +1,3 @@
+MD5 a64337205bc30faa45053965cc957b0e wmhdplop-0.9.9.tar.gz 232684
+RMD160 c983a8261087b4c6289a3b8104d4d3532f71e241 wmhdplop-0.9.9.tar.gz 232684
+SHA256 68f27918a8da4af2389544441eeee3a6fda3a875cd55603a3e04abedc1726553 wmhdplop-0.9.9.tar.gz 232684
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.9.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.9.ebuild
new file mode 100644
index 000000000000..b8c9eeaddc07
--- /dev/null
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/wmhdplop-0.9.9.ebuild,v 1.1 2008/01/17 00:13:25 drac Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="a dockapp for monitoring disk activities with fancy visuals."
+HOMEPAGE="http://hules.free.fr/wmhdplop"
+SRC_URI="http://hules.free.fr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gkrellm"
+
+RDEPEND="media-libs/imlib2
+ x11-libs/libX11
+ x11-libs/libXext
+ media-fonts/corefonts
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ gkrellm? ( dev-util/pkgconfig
+ >=app-admin/gkrellm-2 )"
+
+pkg_setup() {
+ local fail="Re-emerge media-libs/imlib2 with USE X."
+
+ if ! built_with_use media-libs/imlib2 X; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:-O3 -fomit-frame-pointer -ffast-math:${CFLAGS}:" "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_enable gkrellm)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+
+ insinto /usr/$(get_libdir)/gkrellm2/plugins
+ use gkrellm && doins gkhdplop.so
+}