summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-01-26 19:08:12 +0000
committerMatt Turner <mattst88@gentoo.org>2014-01-26 19:08:12 +0000
commit6a8d9dca1590842a201cd44bbbdf081f349c2757 (patch)
tree1b84db364ec7a8c65d0b96ffb7a8d482823f3e1d /x11-proto/xcb-proto
parentStable for x86, wrt bug #479622 (diff)
downloadgentoo-2-6a8d9dca1590842a201cd44bbbdf081f349c2757.tar.gz
gentoo-2-6a8d9dca1590842a201cd44bbbdf081f349c2757.tar.bz2
gentoo-2-6a8d9dca1590842a201cd44bbbdf081f349c2757.zip
Version bump to 1.10, bug 496802.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'x11-proto/xcb-proto')
-rw-r--r--x11-proto/xcb-proto/ChangeLog9
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.10.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index 5f3c9f09eeea..c0c844bb8270 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-proto/xcb-proto
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.126 2013/11/12 02:38:27 mattst88 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.127 2014/01/26 19:08:12 mattst88 Exp $
+
+*xcb-proto-1.10 (26 Jan 2014)
+
+ 26 Jan 2014; Matt Turner <mattst88@gentoo.org> +xcb-proto-1.10.ebuild:
+ Version bump to 1.10, bug 496802.
*xcb-proto-1.9-r1 (12 Nov 2013)
diff --git a/x11-proto/xcb-proto/xcb-proto-1.10.ebuild b/x11-proto/xcb-proto/xcb-proto-1.10.ebuild
new file mode 100644
index 000000000000..0ea3efce3b5d
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.10.ebuild,v 1.1 2014/01/26 19:08:12 mattst88 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_export_best
+ xorg-2_src_configure
+ #Note: multilib is not supported with python, therefore use only one ABI
+ python_parallel_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ xorg-2_src_compile
+
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${WORKDIR}/${P}-${ABI:-${DEFAULT_ABI}}"
+}
+
+src_install() {
+ xorg-2_src_install
+
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${WORKDIR}/${P}-${ABI:-${DEFAULT_ABI}}"
+
+ sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
+ "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
+}