summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-20 20:52:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-20 20:52:34 +0000
commitcd1861e7990f411480867704765752791e2729e5 (patch)
treee2b5ff90ce1cb2a434323aa69ca7290fba7cedf0 /x11-terms/gnome-terminal/gnome-terminal-2.32.0.ebuild
parentstable ppc, bug 341335 (diff)
downloadgentoo-2-cd1861e7990f411480867704765752791e2729e5.tar.gz
gentoo-2-cd1861e7990f411480867704765752791e2729e5.tar.bz2
gentoo-2-cd1861e7990f411480867704765752791e2729e5.zip
Clean up old revisions. Version bump to 2.32. Now licensed under GPL3, add search and save feature, lots of bug fixes.
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms/gnome-terminal/gnome-terminal-2.32.0.ebuild')
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.32.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.32.0.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.32.0.ebuild
new file mode 100644
index 000000000000..1bd4b710299b
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.32.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.32.0.ebuild,v 1.1 2010/10/20 20:52:34 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+# libgnome needed for some monospace font schema, bug #274638
+RDEPEND=">=dev-libs/glib-2.25.12:2
+ >=x11-libs/gtk+-2.18:2
+ >=gnome-base/gconf-2.31.3
+ >=x11-libs/vte-0.25.91
+ x11-libs/libSM
+ gnome-base/libgnome"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3.11"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use login shell by default (#12900)
+ epatch "${FILESDIR}"/${PN}-2.22.0-default_shell.patch
+
+ # patch gnome terminal to report as GNOME rather than xterm
+ # This needs to resolve a few bugs (#120294,)
+ # Leave out for now; causing too many problems
+ #epatch ${FILESDIR}/${PN}-2.13.90-TERM-gnome.patch
+}