summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-16 21:38:47 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-16 21:38:47 +0000
commit55b7227f999d687e45be1d7e91baf1a0a0dab766 (patch)
tree3a3173385290ce7e8aa77304604042eede7a6b13 /x11-terms/rxvt-unicode
parentRemove dev-libs/gmp-5 mask (bug #344613). (diff)
downloadgentoo-2-55b7227f999d687e45be1d7e91baf1a0a0dab766.tar.gz
gentoo-2-55b7227f999d687e45be1d7e91baf1a0a0dab766.tar.bz2
gentoo-2-55b7227f999d687e45be1d7e91baf1a0a0dab766.zip
version bump, bug #345275
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms/rxvt-unicode')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog8
-rw-r--r--x11-terms/rxvt-unicode/metadata.xml1
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.09.ebuild91
3 files changed, 99 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index f44fe562abb3..3477462943ab 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.171 2010/10/23 22:01:50 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.172 2010/11/16 21:38:47 wired Exp $
+
+*rxvt-unicode-9.09 (15 Nov 2010)
+
+ 15 Nov 2010; Alex Alexander <wired@gentoo.org> +rxvt-unicode-9.09.ebuild,
+ metadata.xml:
+ version bump, bug #345275
23 Oct 2010; Mark Loeser <halcy0n@gentoo.org> rxvt-unicode-9.07-r1.ebuild:
Stable for ppc64; bug #319711
diff --git a/x11-terms/rxvt-unicode/metadata.xml b/x11-terms/rxvt-unicode/metadata.xml
index 36bc39cda30c..e3e355410072 100644
--- a/x11-terms/rxvt-unicode/metadata.xml
+++ b/x11-terms/rxvt-unicode/metadata.xml
@@ -11,6 +11,7 @@
<name>Alex Alexander</name>
</maintainer>
<use>
+ <flag name='256-color'>Enable 256 color support</flag>
<flag name='afterimage'>Enable support for
<pkg>media-libs/libafterimage</pkg></flag>
<flag name='iso14755'>Enable ISO-14755 support</flag>
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.09.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.09.ebuild
new file mode 100644
index 000000000000..4fd89396a391
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.09.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.09.ebuild,v 1.1 2010/11/16 21:38:47 wired Exp $
+
+EAPI="3"
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="256-color afterimage iso14755 perl blink truetype +vanilla wcwidth"
+
+# see bug #115992 for modular x deps
+RDEPEND="x11-libs/libX11
+ x11-libs/libXft
+ afterimage? ( || ( media-libs/libafterimage x11-wm/afterstep ) )
+ x11-libs/libXrender
+ perl? ( dev-lang/perl )
+ >=sys-libs/ncurses-5.7-r6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ if use wcwidth; then
+ ewarn "You enabled wcwidth."
+ ewarn "Please note that this is not supported by upstream."
+ ewarn "You are at your own if you run into problems."
+ fi
+
+ local tdir=/usr/share/terminfo
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in ||
+ die "sed failed"
+
+ use wcwidth && epatch doc/wcwidth.patch
+
+ # bug #240165
+ epatch "${FILESDIR}"/${PN}-9.06-no-urgency-if-focused.diff
+
+ # bug #263638
+ epatch "${FILESDIR}"/${PN}-9.06-popups-hangs.patch
+
+ # bug #237271
+ if ! use vanilla; then
+ ewarn "You are going to include third-party bug fixes/features."
+ ewarn "They came without any warranty and are not supported by the"
+ ewarn "Gentoo community."
+ epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
+ epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf --enable-everything \
+ --disable-pixbuf \
+ $(use_enable truetype xft) \
+ $(use_enable 256-color) \
+ $(use_enable afterimage) \
+ $(use_enable perl) \
+ $(use_enable blink text-blink) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}