summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-09 12:02:22 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-09 12:02:22 +0000
commit2052458483537541df5e0e9e53e946327f3db44a (patch)
treedae79b6120b5d7f8f946056bc8ff53891e184f7c /x11-terms/sakura/sakura-3.1.0.ebuild
parentversion bump (diff)
downloadgentoo-2-2052458483537541df5e0e9e53e946327f3db44a.tar.gz
gentoo-2-2052458483537541df5e0e9e53e946327f3db44a.tar.bz2
gentoo-2-2052458483537541df5e0e9e53e946327f3db44a.zip
base_src_prepare => cmake-utils_src_prepare. Version bump. Use strip-linguas instead of hard-coded LANGS.
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-terms/sakura/sakura-3.1.0.ebuild')
-rw-r--r--x11-terms/sakura/sakura-3.1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-terms/sakura/sakura-3.1.0.ebuild b/x11-terms/sakura/sakura-3.1.0.ebuild
new file mode 100644
index 000000000000..b549a3d668a8
--- /dev/null
+++ b/x11-terms/sakura/sakura-3.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/sakura/sakura-3.1.0.ebuild,v 1.1 2013/07/09 12:02:22 jer Exp $
+
+EAPI=5
+inherit cmake-utils eutils
+
+DESCRIPTION="sakura is a terminal emulator based on GTK and VTE"
+HOMEPAGE="http://www.pleyades.net/david/projects/sakura/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.20:2
+ >=x11-libs/vte-0.28:2.90
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.10.1
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1.0-flags.patch )
+
+DOCS=( AUTHORS INSTALL )
+
+src_prepare() {
+ sed -i -e "/FILES INSTALL/d" CMakeLists.txt || die
+
+ strip-linguas -i po/
+ local lingua
+ for lingua in po/*.po; do
+ lingua="${lingua/po\/}"
+ lingua="${lingua/.po}"
+ if ! has ${lingua} ${LINGUAS}; then
+ rm po/${lingua}.po || die
+ fi
+ done
+
+ cmake-utils_src_prepare
+}