summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-06-06 22:06:09 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-06-06 22:06:09 +0000
commit42f50ab7f2ac14b5570ac7ac2961ac7d06f445e7 (patch)
tree25cc9f450ac0024d6aaf5d53ceb0a9eb6cb790a3 /x11-terms
parentDon't specify full path of installed doc files since PORTAGE_COMPRESS comes i... (diff)
downloadgentoo-2-42f50ab7f2ac14b5570ac7ac2961ac7d06f445e7.tar.gz
gentoo-2-42f50ab7f2ac14b5570ac7ac2961ac7d06f445e7.tar.bz2
gentoo-2-42f50ab7f2ac14b5570ac7ac2961ac7d06f445e7.zip
Fix compilation with glibc-2.10, bug 270694. Thanks to Francisco J. Vázquez and Alex 'wired' Alexander for testing.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog9
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-glibc-2.10.patch42
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild7
3 files changed, 54 insertions, 4 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 6f77e24568bd..d87c2467b4d4 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.127 2008/12/21 20:44:23 killerfox Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.128 2009/06/06 22:06:08 loki_val Exp $
+
+ 06 Jun 2009; Peter Alfredsen <loki_val@gentoo.org>
+ rxvt-unicode-9.06.ebuild, +files/rxvt-unicode-9.06-glibc-2.10.patch:
+ Fix compilation with glibc-2.10, bug 270694. Thanks to Francisco J.
+ Vázquez and Alex 'wired' Alexander for testing.
*rxvt-unicode-9.06 (21 Dec 2008)
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-glibc-2.10.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-glibc-2.10.patch
new file mode 100644
index 000000000000..c4c25dbb30c6
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-glibc-2.10.patch
@@ -0,0 +1,42 @@
+--- src/background.C.orig 2009-04-25 01:12:46.000000000 +0200
++++ src/background.C 2009-04-25 01:19:21.000000000 +0200
+@@ -261,7 +261,7 @@
+ unsigned int w = 0, h = 0;
+ unsigned int n;
+ unsigned long new_flags = (flags & (~geometryFlags));
+- char *p;
++ const char *p;
+ # define MAXLEN_GEOM 256 /* could be longer than regular geometry string */
+
+ if (geom == NULL)
+@@ -677,7 +677,7 @@
+ if (!target->asimman)
+ target->asimman = create_generic_imageman (target->rs[Rs_path]);
+
+- if (char *f = strchr (file, ';'))
++ if (char *f = (char *) strchr (file, ';'))
+ {
+ size_t len = f - file;
+ f = (char *)malloc (len + 1);
+--- src/command.C.orig 2009-04-25 01:20:29.000000000 +0200
++++ src/command.C 2009-04-25 01:21:20.000000000 +0200
+@@ -3336,7 +3336,7 @@
+ }
+ else
+ {
+- char *eq = strchr (str, '='); // constness lost, but verified to be ok
++ char *eq = (char *) strchr (str, '='); // constness lost, but verified to be ok
+
+ if (eq)
+ {
+--- src/misc.C.orig 2009-04-25 01:41:05.000000000 +0200
++++ src/misc.C 2009-04-25 01:41:37.000000000 +0200
+@@ -170,7 +170,7 @@
+ char *
+ rxvt_basename (const char *str) NOTHROW
+ {
+- char *base = strrchr (str, '/');
++ char *base = (char *) strrchr (str, '/');
+
+ return (char *) (base ? base + 1 : str);
+ }
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild
index 56f92cf71b57..f6ad0cc05858 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild,v 1.1 2008/12/21 20:44:23 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild,v 1.2 2009/06/06 22:06:08 loki_val Exp $
inherit autotools flag-o-matic
@@ -27,6 +27,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ #Bug 270694
+ epatch "${FILESDIR}/${PN}-9.06-glibc-2.10.patch"
+
if (use xterm-color || use wcwidth); then
ewarn "You enabled xterm-color or wcwidth or both."
ewarn "Please note that neither of them are supported by upstream."