summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-01-31 19:43:27 +0000
committerMichael Januszewski <spock@gentoo.org>2004-01-31 19:43:27 +0000
commit9f0983d665d3ad8d7eed20d8e2ce56118d0cc850 (patch)
treeaac13f18b1fd229abfcd7275051561d240c75d2f /x11-terms
parentremove obsolete patch (Manifest recommit) (diff)
downloadgentoo-2-9f0983d665d3ad8d7eed20d8e2ce56118d0cc850.tar.gz
gentoo-2-9f0983d665d3ad8d7eed20d8e2ce56118d0cc850.tar.bz2
gentoo-2-9f0983d665d3ad8d7eed20d8e2ce56118d0cc850.zip
Added patch for pasting large amounts of text an a bunch of patches taken from Debian.
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/aterm/ChangeLog13
-rw-r--r--x11-terms/aterm/aterm-0.4.2-r8.ebuild82
-rw-r--r--x11-terms/aterm/files/aterm-0.4.2-patch-pack000.patch140
-rw-r--r--x11-terms/aterm/files/digest-aterm-0.4.2-r82
4 files changed, 236 insertions, 1 deletions
diff --git a/x11-terms/aterm/ChangeLog b/x11-terms/aterm/ChangeLog
index ccfea3102409..81b9f1b5c7e1 100644
--- a/x11-terms/aterm/ChangeLog
+++ b/x11-terms/aterm/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for x11-terms/aterm
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/aterm/ChangeLog,v 1.17 2004/01/17 18:09:33 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/aterm/ChangeLog,v 1.18 2004/01/31 19:43:27 spock Exp $
+
+*aterm-0.4.2-r8 (31 Jan 2004)
+
+ 31 Jan 2004; Michal Januszewski <spock@gentoo.org> aterm-0.4.2-r8.ebuild,
+ files/aterm-0.4.2-patch-pack000.patch:
+ Added a patch for pasting large amounts of texts (thanks to Mina Naguib for
+ submitting it on bug #37733), added a bunch of patches taken from Debian.
+ These have all been merged into one file - patch-pack000.patch. They can
+ downloaded from
+ http://dev.gentoo.org/~spock/stuff/aterm-0.4.2-patchpack000.tar.bz2
+ as separate files in a tar.bz2 archive.
*aterm-0.4.2-r7 (17 Jan 2004)
diff --git a/x11-terms/aterm/aterm-0.4.2-r8.ebuild b/x11-terms/aterm/aterm-0.4.2-r8.ebuild
new file mode 100644
index 000000000000..6e8c947bda49
--- /dev/null
+++ b/x11-terms/aterm/aterm-0.4.2-r8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/aterm/aterm-0.4.2-r8.ebuild,v 1.1 2004/01/31 19:43:27 spock Exp $
+
+IUSE="cjk"
+S=${WORKDIR}/${P}
+DESCRIPTION="A terminal emulator with transparency support as well as rxvt backwards compatibility"
+SRC_URI="mirror://sourceforge/aterm/${P}.tar.bz2
+ cjk? (http://wakaba.com/~tsann/aterm/aterm-0.4.2-ja.patch)"
+HOMEPAGE="http://aterm.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+DEPEND="media-libs/jpeg
+ media-libs/libpng
+ virtual/x11"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}/src
+ cp feature.h feature.h.orig
+ sed "s:\(#define LINUX_KEYS\):/\*\1\*/:" \
+ feature.h.orig > feature.h
+
+ cd ${S}
+ epatch ${FILESDIR}/aterm-0.4.2-borderless.patch
+ epatch ${FILESDIR}/aterm-0.4.2-paste.patch
+ epatch ${FILESDIR}/aterm-0.4.2-paste_mouse_outside.patch
+
+ if [ `use cjk` ] ; then
+ epatch ${DISTDIR}/aterm-0.4.2-ja.patch
+ else
+ epatch ${FILESDIR}/aterm-0.4.2-copynpaste-r2.patch
+ fi
+
+ epatch ${FILESDIR}/aterm-0.4.2-patch-pack000.patch
+}
+
+src_compile() {
+ local myconf
+
+ # You can't --enable-big5 with aterm-0.4.2-ja.patch
+ # I think it's very bad thing but as nobody complains it
+ # and we don't have per-language flag atm, I stick to
+ # use --enable-kanji/--enable-thai (and leave --enable-big5)
+ use cjk && myconf="$myconf
+ --enable-kanji
+ --enable-thai
+ --enable-xim
+ --enable-linespace"
+
+ econf \
+ --enable-transparency \
+ --enable-fading \
+ --enable-background-image \
+ --enable-menubar \
+ --enable-graphics \
+ --enable-utmp \
+ --with-x \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ fperms g+s /usr/bin/aterm
+ fowners root:utmp /usr/bin/aterm
+
+ doman doc/aterm.1
+ dodoc ChangeLog INSTALL doc/BUGS doc/FAQ doc/README.*
+ docinto menu
+ dodoc doc/menu/*
+ dohtml -r .
+
+ einfo
+ einfo "Hint: you can copy text from aterm to the clipboard by holding the ALT key"
+ einfo "while highlighting the text."
+ einfo
+}
diff --git a/x11-terms/aterm/files/aterm-0.4.2-patch-pack000.patch b/x11-terms/aterm/files/aterm-0.4.2-patch-pack000.patch
new file mode 100644
index 000000000000..768a5031f37b
--- /dev/null
+++ b/x11-terms/aterm/files/aterm-0.4.2-patch-pack000.patch
@@ -0,0 +1,140 @@
+diff -Naur aterm-0.4.2-orig/src/command.c aterm-0.4.2/src/command.c
+--- aterm-0.4.2-orig/src/command.c 2001-09-06 18:38:07.000000000 +0200
++++ aterm-0.4.2/src/command.c 2004-01-31 20:13:29.442207872 +0100
+@@ -975,6 +975,8 @@
+ signal(SIGTERM, Exit_signal);
+ signal(SIGCHLD, Child_signal);
+
++ tt_winsize(ptyfd); /* set window size */
++
+ /* need to trap SIGURG for SVR4 (Unixware) rlogin */
+ /* signal (SIGURG, SIG_DFL); */
+
+@@ -1014,7 +1016,6 @@
+ }
+ #endif /* SRIOCSREDIR */
+ }
+- tt_winsize(0); /* set window size */
+
+ /* reset signals and spin off the command interpreter */
+ signal(SIGINT, SIG_DFL);
+@@ -2025,19 +2026,21 @@
+
+ /* See if we can read from the application */
+ if (FD_ISSET(cmd_fd, &readfds)) {
+- unsigned int count = BUFSIZ;
++ int n;
++ unsigned int count;
+
+ cmdbuf_ptr = cmdbuf_endp = cmdbuf_base;
+-
+- /* while (count > sizeof(cmdbuf_base) / 2) */
+- while (count) {
+- int n = read(cmd_fd, cmdbuf_endp, count);
+-
+- if (n <= 0)
++ for (count = BUFSIZ; count; count -= n, cmdbuf_endp += n)
++ if ((n = read(cmd_fd, cmdbuf_endp, count)) > 0)
++ continue;
++ else if (n == 0 || (n < 0 && errno == EAGAIN))
+ break;
+- cmdbuf_endp += n;
+- count -= n;
+- }
++ else {
++#if !defined (HAVE_ATEXIT) && !defined (__sun__)
++ clean_exit();
++#endif
++ exit(EXIT_SUCCESS);
++ }
+ /* some characters read in */
+ if (count != BUFSIZ)
+ goto Return_Char;
+@@ -2116,6 +2119,11 @@
+ + (MEvent.clicks > 1 ? 8 : 0)
+ #endif
+ ) << 2);
++ /* Report mouse wheel events. */
++ if (ev->button == Button4 || ev->button == Button5) {
++ key_state |= 1 << 6;
++ button_number = ev->button - Button4;
++ }
+ }
+
+ #ifdef DEBUG_MOUSEREPORT
+@@ -2315,10 +2323,7 @@
+ if( TermWin.background.trgType != BGT_None )
+ {
+ SetSrcPixmap(currentRPixmap);
+- RenderPixmap(1);
+- /* don't want to check if pixmap is valid
+- it's unlikely that user would set it to
+- something bogus. */
++ RenderPixmap(0);
+ }
+ scr_clear();
+ scr_touch();
+@@ -2623,6 +2628,9 @@
+ Gr_ButtonRelease(ev->xbutton.x, ev->xbutton.y);
+ else {
+ if (reportmode) {
++ /* Don't report release events for the mouse wheel */
++ if (ev->xbutton.button == Button4 || ev->xbutton.button == Button5)
++ return;
+ /* mouse report from vt window */
+ #ifdef MOUSE_REPORT_DOUBLECLICK
+ /* only report the release of 'slow' single clicks */
+diff -Naur aterm-0.4.2-orig/src/main.c aterm-0.4.2/src/main.c
+--- aterm-0.4.2-orig/src/main.c 2001-09-06 18:38:07.000000000 +0200
++++ aterm-0.4.2/src/main.c 2004-01-31 20:13:29.432209392 +0100
+@@ -129,11 +129,6 @@
+
+ /*}}} */
+
+-/* have we changed the font? Needed to avoid raceconditions
+- * while window resizing */
+-static int font_change_count = 0;
+-
+-
+ /*----------------------------------------------------------------------*/
+ /* ARGSUSED */
+ /* PROTO */
+@@ -917,12 +912,6 @@
+ int x, y;
+ unsigned int border, depth, width, height, vt_width, vt_height;
+
+-/* do we come from an fontchange? */
+- if (font_change_count > 0) {
+- font_change_count--;
+- return;
+- }
+-
+ resize_window1((ev->xconfigure).width, (ev->xconfigure).height);
+
+ #if defined(TRANSPARENT) || defined(BACKGROUND_IMAGE) || defined(_MYSTYLE_)
+@@ -936,17 +925,11 @@
+ {
+ unsigned w, h;
+ XEvent evt ;
+- int bNoTint = 0 ;
+ /* that is to make it working smooth with AfterStep shading*/
+ if( XCheckMaskEvent(Xdisplay, StructureNotifyMask, &evt ))
+ {
+- /* printf( "\n there are more ConfigureNotifyEvents there !");*/
+- if( evt.xany.type == ConfigureNotify ) bNoTint = 1 ;
+ XPutBackEvent( Xdisplay, &evt );
+ }
+- if( bNoTint )
+- scr_clear_tint(0); /* no tinting for faster redraw */
+- else
+ {
+ int abs_x, abs_y;
+ static int old_abs_x=0, old_abs_y=0,
+@@ -1417,7 +1400,6 @@
+ szHint.flags = PMinSize | PResizeInc | PBaseSize | PWinGravity;
+
+ if (!init) {
+- font_change_count++;
+ resize();
+ }
+ return;
diff --git a/x11-terms/aterm/files/digest-aterm-0.4.2-r8 b/x11-terms/aterm/files/digest-aterm-0.4.2-r8
new file mode 100644
index 000000000000..a1aafd5e085e
--- /dev/null
+++ b/x11-terms/aterm/files/digest-aterm-0.4.2-r8
@@ -0,0 +1,2 @@
+MD5 5c29d0cde4225bdbd63ccb6a4dd94c56 aterm-0.4.2.tar.bz2 243419
+MD5 2bd8629ea2a1926bca13841b0aca6604 aterm-0.4.2-ja.patch 84282