summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-24 13:49:58 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-24 13:49:58 +0000
commit5edac1f2bca1595759b7bd0ec1dcbdc35d7e1c78 (patch)
tree893d47ce3449c5bbfc63e2c74fdd904ab36807b1 /x11-themes/gnome-themes-standard
parentVersion bump (diff)
downloadgentoo-2-5edac1f2bca1595759b7bd0ec1dcbdc35d7e1c78.tar.gz
gentoo-2-5edac1f2bca1595759b7bd0ec1dcbdc35d7e1c78.tar.bz2
gentoo-2-5edac1f2bca1595759b7bd0ec1dcbdc35d7e1c78.zip
Version bump.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-themes/gnome-themes-standard')
-rw-r--r--x11-themes/gnome-themes-standard/ChangeLog8
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.6.5.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/x11-themes/gnome-themes-standard/ChangeLog b/x11-themes/gnome-themes-standard/ChangeLog
index d3461227014e..30c55c4b42d5 100644
--- a/x11-themes/gnome-themes-standard/ChangeLog
+++ b/x11-themes/gnome-themes-standard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gnome-themes-standard
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.38 2013/02/25 21:13:10 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.39 2013/03/24 13:49:58 eva Exp $
+
+*gnome-themes-standard-3.6.5 (24 Mar 2013)
+
+ 24 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-themes-standard-3.6.5.ebuild:
+ Version bump.
25 Feb 2013; Zac Medico <zmedico@gentoo.org>
gnome-themes-standard-3.6.2.ebuild:
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.6.5.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.6.5.ebuild
new file mode 100644
index 000000000000..2f7027a6708e
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.6.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.6.5.ebuild,v 1.1 2013/03/24 13:49:58 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Adwaita theme for GNOME Shell"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gtk"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ >=x11-themes/gtk-engines-2.15.3:2
+ gtk? (
+ >=x11-libs/gtk+-2.24.15:2
+ >=x11-libs/gtk+-3.6.2:3 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-3.4
+ !<x11-themes/gnome-themes-2.32.1-r1
+"
+
+src_prepare() {
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i themes/Adwaita/cursors/Makefile.am \
+ -i themes/Adwaita/cursors/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # The icon cache needs to be generated in pkg_postinst()
+ gnome2_src_configure \
+ --disable-static \
+ --disable-placeholders \
+ $(use_enable gtk gtk2-engine) \
+ $(use_enable gtk gtk3-engines) \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Make it the default cursor theme
+ dosym Adwaita /usr/share/cursors/xorg-x11/default
+}