summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-02 16:54:41 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-02 16:54:41 +0000
commite04dbf15c6b3cf13e15373f4ab0df3b32b077106 (patch)
tree706a3ddf70716d7a522fda3198673ae294524b59 /x11-themes/gnome-themes-standard
parentUsing use_with in the caps-ng use flag case, thanks to leio for the heads up (diff)
downloadgentoo-2-e04dbf15c6b3cf13e15373f4ab0df3b32b077106.tar.gz
gentoo-2-e04dbf15c6b3cf13e15373f4ab0df3b32b077106.tar.bz2
gentoo-2-e04dbf15c6b3cf13e15373f4ab0df3b32b077106.zip
Bump to 3.0.2
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gnome-themes-standard')
-rw-r--r--x11-themes/gnome-themes-standard/ChangeLog8
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.0.2.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/x11-themes/gnome-themes-standard/ChangeLog b/x11-themes/gnome-themes-standard/ChangeLog
index 1edaf4725905..5a3108ba21ff 100644
--- a/x11-themes/gnome-themes-standard/ChangeLog
+++ b/x11-themes/gnome-themes-standard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gnome-themes-standard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.1 2011/05/01 13:02:30 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.2 2011/06/02 16:54:41 nirbheek Exp $
+
+*gnome-themes-standard-3.0.2 (02 Jun 2011)
+
+ 02 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gnome-themes-standard-3.0.2.ebuild:
+ Bump to 3.0.2
*gnome-themes-standard-3.0.1 (01 May 2011)
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.0.2.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.0.2.ebuild
new file mode 100644
index 000000000000..a9d589a2b2d8
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.0.2.ebuild,v 1.1 2011/06/02 16:54:41 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Adwaita theme for GNOME Shell"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND=">=x11-libs/gtk+-3.0.8:3
+ >=x11-themes/gtk-engines-2.15.3:2"
+DEPEND="${COMMON_DEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.40
+ sys-devel/gettext"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+RDEPEND="${COMMON_DEPEND}
+ !x11-themes/gnome-themes
+ !x11-themes/gnome-themes-extras"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+# FIXME: --enable-placeholders fails
+G2CONF="--disable-static --disable-placeholders"
+DOCS="ChangeLog NEWS"
+
+src_prepare() {
+ gnome2_src_prepare
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i themes/Adwaita/cursors/Makefile.am \
+ -i themes/Adwaita/cursors/Makefile.in || die
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Make it the default cursor theme
+ cd "${ED}/usr/share/cursors/xorg-x11" || die
+ ln -sfn Adwaita default || die
+}