summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-10-09 19:34:15 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-10-09 19:34:15 +0000
commitfdd2bfb22eeff055d511064221056ce4125b503a (patch)
tree4b73365618bead45da38e4657cc30a5e97ee8cf7 /x11-themes/gtk-engines-qtcurve
parentRevision bump to use correct blocker on kmail. (diff)
downloadgentoo-2-fdd2bfb22eeff055d511064221056ce4125b503a.tar.gz
gentoo-2-fdd2bfb22eeff055d511064221056ce4125b503a.tar.bz2
gentoo-2-fdd2bfb22eeff055d511064221056ce4125b503a.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines-qtcurve')
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.69.0.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index 72e75e6117a6..ffdac4afb868 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.67 2009/09/27 14:41:56 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.68 2009/10/09 19:34:15 nelchael Exp $
+
+*gtk-engines-qtcurve-0.69.0 (09 Oct 2009)
+
+ 09 Oct 2009; Krzysiek Pawlik <nelchael@gentoo.org>
+ +gtk-engines-qtcurve-0.69.0.ebuild:
+ Version bump.
27 Sep 2009; nixnut <nixnut@gentoo.org> gtk-engines-qtcurve-0.65.2.ebuild:
ppc stable #279585
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.69.0.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.69.0.ebuild
new file mode 100644
index 000000000000..ca8a7dfaf531
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.69.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.69.0.ebuild,v 1.1 2009/10/09 19:34:15 nelchael Exp $
+
+EAPI=1
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozilla firefox3"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ firefox3? ( || ( >=www-client/mozilla-firefox-3.0
+ >=www-client/mozilla-firefox-bin-3.0 ) )"
+DEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_compile() {
+ local mycmakeargs=""
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_OLD_MOZILLA=true"
+ use firefox3 && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_OLD_MOZILLA=false"
+ cmake-utils_src_compile
+}