summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-14 13:38:23 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-14 13:38:23 +0000
commit9741e2007165be3a8ef4a2de0b346571cfe11518 (patch)
tree351252d68f0b605d0daf75211bec0b7a52d04d6c /x11-themes/gtk-engines
parentAdd multilib atk & gtk+. Also remove files for gtk-engines but do not pull th... (diff)
downloadgentoo-2-9741e2007165be3a8ef4a2de0b346571cfe11518.tar.gz
gentoo-2-9741e2007165be3a8ef4a2de0b346571cfe11518.tar.bz2
gentoo-2-9741e2007165be3a8ef4a2de0b346571cfe11518.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'x11-themes/gtk-engines')
-rw-r--r--x11-themes/gtk-engines/ChangeLog9
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/x11-themes/gtk-engines/ChangeLog b/x11-themes/gtk-engines/ChangeLog
index e3eab80563ce..8bfd2978edc7 100644
--- a/x11-themes/gtk-engines/ChangeLog
+++ b/x11-themes/gtk-engines/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/gtk-engines
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.187 2013/02/25 21:09:20 zmedico Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.188 2014/05/14 13:38:23 mgorny Exp $
+
+*gtk-engines-2.20.2-r1 (14 May 2014)
+
+ 14 May 2014; Michał Górny <mgorny@gentoo.org> +gtk-engines-2.20.2-r1.ebuild:
+ Enable multilib support.
25 Feb 2013; Zac Medico <zmedico@gentoo.org> gtk-engines-2.20.2.ebuild:
Add ~arm-linux keyword.
diff --git a/x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild b/x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild
new file mode 100644
index 000000000000..fdda9bc4aee7
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild,v 1.1 2014/05/14 13:38:23 mgorny Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="GTK+2 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility lua"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2[${MULTILIB_USEDEP}]
+ lua? ( dev-lang/lua )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+GNOME2_LA_PUNT="yes"
+
+src_prepare() {
+ # Patch from 2.21.x, fixes building with glib-2.32, bug #410455
+ epatch "${FILESDIR}/${P}-glib.h.patch"
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --enable-animation \
+ $(multilib_native_use_enable lua) \
+ $(multilib_native_use_with lua system-lua) \
+ $(use_enable accessibility hc)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS ChangeLog NEWS README )
+ einstalldocs
+}