summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-01 12:23:06 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-01 12:23:06 +0000
commit28147b22a0d1f497c55246874f1ca19fcd8e8213 (patch)
treec0f1a5b5c022cce84350b3e63d4018ab9d5aea4d /x11-themes
parentCleanup due bug #151880 (diff)
downloadgentoo-2-28147b22a0d1f497c55246874f1ca19fcd8e8213.tar.gz
gentoo-2-28147b22a0d1f497c55246874f1ca19fcd8e8213.tar.bz2
gentoo-2-28147b22a0d1f497c55246874f1ca19fcd8e8213.zip
Version bump in slot 2 and 3.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/oxygen-gtk/ChangeLog9
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.1.4.ebuild52
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.3.4.ebuild52
3 files changed, 112 insertions, 1 deletions
diff --git a/x11-themes/oxygen-gtk/ChangeLog b/x11-themes/oxygen-gtk/ChangeLog
index f009faeb70c2..9aca005b970f 100644
--- a/x11-themes/oxygen-gtk/ChangeLog
+++ b/x11-themes/oxygen-gtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/oxygen-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.53 2013/04/26 18:01:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.54 2013/06/01 12:23:06 johu Exp $
+
+*oxygen-gtk-1.3.4 (01 Jun 2013)
+*oxygen-gtk-1.1.4 (01 Jun 2013)
+
+ 01 Jun 2013; Johannes Huber <johu@gentoo.org> +oxygen-gtk-1.1.4.ebuild,
+ +oxygen-gtk-1.3.4.ebuild:
+ Version bump in slot 2 and 3.
*oxygen-gtk-1.1.3 (26 Apr 2013)
*oxygen-gtk-1.3.3 (26 Apr 2013)
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.1.4.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.1.4.ebuild
new file mode 100644
index 000000000000..bd3f40bc670d
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.1.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.1.4.ebuild,v 1.3 2013/06/01 12:23:06 johu Exp $
+
+EAPI=5
+
+MY_PN=${PN}3
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+:3 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="3"
+IUSE="debug doc"
+
+RDEPEND="
+ !x11-themes/oxygen-gtk:0
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( AUTHORS README TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk3
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-3.0"
+EOF
+ doenvd 99oxygen-gtk3
+}
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.3.4.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.3.4.ebuild
new file mode 100644
index 000000000000..63f63632759e
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.3.4.ebuild,v 1.1 2013/06/01 12:23:06 johu Exp $
+
+EAPI=5
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+:2 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="2"
+IUSE="debug doc"
+
+RDEPEND="
+ !x11-themes/oxygen-gtk:0
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-2.24.2:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( AUTHORS README TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk2
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-2.0"
+EOF
+ doenvd 99oxygen-gtk2
+}