summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-08 14:55:02 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-08 14:55:02 +0000
commitaa2dc8748b2b0efc2ac6a9540abe2ba383e5bf3b (patch)
treeba8253dc51561d0f889878b5a50b16c11d9edf41 /x11-themes
parentDo not export PYTHON_INCLUDEDIR on Jython, since it does not install headers. (diff)
downloadgentoo-2-aa2dc8748b2b0efc2ac6a9540abe2ba383e5bf3b.tar.gz
gentoo-2-aa2dc8748b2b0efc2ac6a9540abe2ba383e5bf3b.tar.bz2
gentoo-2-aa2dc8748b2b0efc2ac6a9540abe2ba383e5bf3b.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-themes-standard/ChangeLog8
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/x11-themes/gnome-themes-standard/ChangeLog b/x11-themes/gnome-themes-standard/ChangeLog
index 4370f932d6cd..b337bcc687de 100644
--- a/x11-themes/gnome-themes-standard/ChangeLog
+++ b/x11-themes/gnome-themes-standard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gnome-themes-standard
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.44 2013/07/28 19:43:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.45 2013/09/08 14:55:02 eva Exp $
+
+*gnome-themes-standard-3.8.4 (08 Sep 2013)
+
+ 08 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-themes-standard-3.8.4.ebuild:
+ Version bump.
*gnome-themes-standard-3.8.3 (28 Jul 2013)
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4.ebuild
new file mode 100644
index 000000000000..7161cae14516
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4.ebuild,v 1.1 2013/09/08 14:55:02 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gtk"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ >=x11-themes/gtk-engines-2.15.3:2
+ gtk? (
+ >=x11-libs/gtk+-2.24.15:2
+ >=x11-libs/gtk+-3.6.2:3 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-3.4
+ !<x11-themes/gnome-themes-2.32.1-r1
+"
+
+src_prepare() {
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i themes/Adwaita/cursors/Makefile.am \
+ -i themes/Adwaita/cursors/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # The icon cache needs to be generated in pkg_postinst()
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable gtk gtk2-engine) \
+ $(use_enable gtk gtk3-engine) \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Make it the default cursor theme
+ dosym Adwaita /usr/share/cursors/xorg-x11/default
+}