summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-05 11:09:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-05 11:09:48 +0000
commitd6f1897f41b97901d74b1f476a472975ac7c8764 (patch)
tree60f9fc976ffc868fa24678c6b8e9a7b262f75b8f /x11-themes
parentAlphabetize here too (diff)
downloadgentoo-2-d6f1897f41b97901d74b1f476a472975ac7c8764.tar.gz
gentoo-2-d6f1897f41b97901d74b1f476a472975ac7c8764.tar.bz2
gentoo-2-d6f1897f41b97901d74b1f476a472975ac7c8764.zip
Import patch for memory leaking from upstream bugzilla wrt #408529
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-xfce/ChangeLog9
-rw-r--r--x11-themes/gtk-engines-xfce/files/gtk-engines-xfce-3.0.0-destroy_gradient.patch11
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r201.ebuild34
3 files changed, 53 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-xfce/ChangeLog b/x11-themes/gtk-engines-xfce/ChangeLog
index 2b91375e9e20..e4dabe4ad632 100644
--- a/x11-themes/gtk-engines-xfce/ChangeLog
+++ b/x11-themes/gtk-engines-xfce/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/gtk-engines-xfce
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.153 2012/06/17 18:33:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.154 2012/09/05 11:09:48 ssuominen Exp $
+
+*gtk-engines-xfce-3.0.0-r201 (05 Sep 2012)
+
+ 05 Sep 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +gtk-engines-xfce-3.0.0-r201.ebuild,
+ +files/gtk-engines-xfce-3.0.0-destroy_gradient.patch:
+ Import patch for memory leaking from upstream bugzilla wrt #408529
17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
-gtk-engines-xfce-2.99.0-r200.ebuild, -gtk-engines-xfce-2.99.0-r300.ebuild,
diff --git a/x11-themes/gtk-engines-xfce/files/gtk-engines-xfce-3.0.0-destroy_gradient.patch b/x11-themes/gtk-engines-xfce/files/gtk-engines-xfce-3.0.0-destroy_gradient.patch
new file mode 100644
index 000000000000..8f92cc71f279
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/files/gtk-engines-xfce-3.0.0-destroy_gradient.patch
@@ -0,0 +1,11 @@
+http://bugs.gentoo.org/show_bug.cgi?id=408529
+http://bugzilla.xfce.org/show_bug.cgi?id=8521
+
+--- gtk-2.0/gradient_draw.c
++++ gtk-2.0/gradient_draw.c
+@@ -278,4 +278,5 @@ void gradient_draw_shaded(cairo_t *cr, gint x, gint y, gint width, gint height,
+ cairo_fill (cr);
+
+ cairo_restore(cr);
++ cairo_pattern_destroy(gradient);
+ }
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r201.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r201.ebuild
new file mode 100644
index 000000000000..823bde58cf32
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r201.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r201.ebuild,v 1.1 2012/09/05 11:09:48 ssuominen Exp $
+
+EAPI=4
+MY_PN=gtk-xfce-engine
+inherit xfconf
+
+DESCRIPTION="A port of Xfce engine to GTK+-2.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-destroy_gradient.patch )
+
+ XFCONF=(
+ --disable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}