summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-25 23:48:27 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-25 23:48:27 +0000
commitdbdd09a06dab69264d1f87b7de9a872fb31416c6 (patch)
treeacb6de7358176fbf38995739bb1294de9f61b3ac /x11-themes
parentversion bumpage (Manifest recommit) (diff)
downloadgentoo-2-dbdd09a06dab69264d1f87b7de9a872fb31416c6.tar.gz
gentoo-2-dbdd09a06dab69264d1f87b7de9a872fb31416c6.tar.bz2
gentoo-2-dbdd09a06dab69264d1f87b7de9a872fb31416c6.zip
fix build with gtk+-2.4
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-theme-switch/ChangeLog5
-rw-r--r--x11-themes/gtk-theme-switch/files/gtk-theme-switch-2.0.0_rc2-gtk+-2.4_fix.patch11
-rw-r--r--x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r1.ebuild6
-rw-r--r--x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2.ebuild11
4 files changed, 30 insertions, 3 deletions
diff --git a/x11-themes/gtk-theme-switch/ChangeLog b/x11-themes/gtk-theme-switch/ChangeLog
index aedb82a618a9..7c0e630a4862 100644
--- a/x11-themes/gtk-theme-switch/ChangeLog
+++ b/x11-themes/gtk-theme-switch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-themes/gtk-theme-switch
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/ChangeLog,v 1.8 2004/03/14 00:47:11 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/ChangeLog,v 1.9 2004/03/25 23:48:27 foser Exp $
+
+ 26 Mar 2004; foser <foser@gentoo.org> gtk-theme-switch-2*.ebuild :
+ Fix build with gtk+-2.4 (#45105)
13 Mar 2004; Stephen P. Becker <geoman@gentoo.org>
gtk-theme-switch-2.0.0_rc2-r1.ebuild:
diff --git a/x11-themes/gtk-theme-switch/files/gtk-theme-switch-2.0.0_rc2-gtk+-2.4_fix.patch b/x11-themes/gtk-theme-switch/files/gtk-theme-switch-2.0.0_rc2-gtk+-2.4_fix.patch
new file mode 100644
index 000000000000..637a984b753a
--- /dev/null
+++ b/x11-themes/gtk-theme-switch/files/gtk-theme-switch-2.0.0_rc2-gtk+-2.4_fix.patch
@@ -0,0 +1,11 @@
+--- Make.old 2004-03-24 19:20:49.450228544 -0800
++++ Makefile 2004-03-24 19:21:06.603620832 -0800
+@@ -2,7 +2,7 @@
+ PREFIX=/usr/local
+ CFLAGS = -O2 -Wall $(shell pkg-config --cflags gtk+-2.0)
+ LIBS = $(shell pkg-config --libs gtk+-2.0)
+-CFLAGS += -DGTK_DISABLE_BROKEN -DGTK_DISABLE_DEPRECATED
++CFLAGS += -DGTK_DISABLE_BROKEN
+
+ VERSION = 2.0.0rc2
+ all: switch
diff --git a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r1.ebuild b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r1.ebuild
index a49f99eb783e..83e4d4de997e 100644
--- a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r1.ebuild
+++ b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r1.ebuild,v 1.5 2004/03/14 00:47:11 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r1.ebuild,v 1.6 2004/03/25 23:48:27 foser Exp $
MY_P=${P/_/}
S=${WORKDIR}/${MY_P}
@@ -19,6 +19,10 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${WORKDIR}/${MY_P}b.patch
+
+ # fix compilation with gtk+-2.4 (#45105)
+ epatch ${FILESDIR}/${P}-gtk+-2.4_fix.patch
+
}
src_compile() {
diff --git a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2.ebuild b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2.ebuild
index 7d274b42266c..78789d318f22 100644
--- a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2.ebuild
+++ b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2.ebuild,v 1.10 2004/02/22 22:41:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2.ebuild,v 1.11 2004/03/25 23:48:27 foser Exp $
MY_P=${P/_/}
S=${WORKDIR}/${MY_P}
@@ -13,6 +13,15 @@ DEPEND="=x11-libs/gtk+-2*"
SLOT="2"
KEYWORDS="x86 ppc sparc alpha"
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # Fix build with gtk+-2.4 (#45105)
+ epatch ${FILESDIR}/${P}-gtk+-2.4_fix.patch
+
+}
+
src_compile() {
make || die
}